Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-22-2021, 04:30 PM   #1
Member
 
Join Date: Sep 2017
Posts: 99
Onan 4000 generator cranks but won't start

Hi all,


I have a 2015 Cummins Onan RV QG 4000 generator. It has somewhere between 300-1000hrs (not sure, I've only owned it for about 2 years and it was a previous rental...might not be the original generator on this RV and I don't trust the hour meter coming from the rental company). About 1 year ago, I replaced the oil, air filter, and spark plug. Since then there has been 50-100 hours. Up until recently it has been working fine.


Recently, it won't start. It cranks and cranks very strong, but doesn't start.


To troubleshoot so far here is what I have done to no avail...

- I have a full tank of gas in the motorhome.
- The motorhome is level.
- Altitude adjustment set to 0 (I am near sea level).

- I checked the oil to make sure there wasn't too much (it is to the low end on the dipstick as most seem to recommend).
- I swapped in a good spark plug to make sure that wasn't the problem, and it didn't fix it.

- I checked the air filter and it seems fine (...even tried starting it without the air filter and it didn't start).
- I changed the fuel filter with a new one, primed it and tried starting it several times and that didn't fix the problem.
- I disconnected all the batteries (and my solar) per someone's suggestion to "reset" the generator. Hooked everything back up and it still didn't fix the problem.



It still cranks very strong...just doesn't start.


The only error code I could get from the lights was '4' (which is over-cranking). I don't think in all the testing that I did I ever let it crank for more than 10-20 seconds at a time.


I have reached the current extent of my generator knowledge! lol.... I'm hoping some of you can help me expand that knowledge with some more suggestions/recommendations.



One thing I've learned about owning an RV (...I actually have 3 now) is that it makes sense to try to learn to fix as much yourself as possible because RV mechanics are a)busy, b)expensive, and c)a hassle to drop off/pick up/etc. Plus, it's fun/satisfying when we can fix our own rigs and not be as dependent on others.



Thanks in advance!
Chris
SJ-Chris is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-22-2021, 06:32 PM   #2
Senior Member
 
Winnebago Owners Club
Carolina Campers
Join Date: Sep 2019
Location: NC
Posts: 140
I totally agree with learning as much as you can. The next thing I would try is taking the spark plug out, connect the wire on top and see if it generates a spark when you are turning it over. If you do, you should be good for electric, next I would check that fuel is making it all the way tot he carburettor - fuel pump - but it sounds like that was working OK.
__________________
GrantR
Itasca Ellipse
Silverado Duramax Toad
GrantR is offline   Reply With Quote
Old 07-22-2021, 06:38 PM   #3
Senior Member
 
Winnebago Owners Club
Join Date: Aug 2019
Location: Meshoppen, PA
Posts: 1,172
check for a strong spark when cranking, plug out of motor, put plug in wire and ground it,, crank.. should spark nice and blue,,

I f not, then let us know,,

I have one that did not spark it was the lick up on the flywheel,, pain to fix.. I replaced genny it was a 1996 ,, 348 hours but,,,,
sibe is offline   Reply With Quote
Old 07-22-2021, 08:54 PM   #4
Member
 
Join Date: Sep 2017
Posts: 99
Update:

I checked the spark plug. Took it out, then plugged it back into the wire connector and put it against the metal of the engine and when the engine cranked it produced rapid sparks. Yellow/white/orange in color (not blue). Is that significant?

Then I put the spark plug back in.

Then I took off the air filter and I sprayed some starter fluid into the carb area. At least that's what I tried to do. The spray can had a ~4" straw that helped me aim towards the carb opening but wasn't long enough for me to get it 100% into the carb, and because of the angle it was hard to see exactly what I was doing. I gave it 3-4 blast while manually holding the carb flap open. Then I tried starting it up. Didn't seem to make much of an impact and the engine just still cranked and cranked but didn't really seem to get any further. I tried spraying starter fluid 2-3 times more and still nothing. Because of some residual starter fluid spraying into the carb area (the housing that holds the air filter) at one point there was a tiny fire that started burning the excess fuel. I put it out within 5-10 seconds and it didn't look like it had any damage whatsoever. (I had a fire extinguisher next to me during all of this just in case!) Does this imply it is receiving the spark from the spark plug??

I'm not sure where to go from here. Any thoughts??

Thanks!
Chris
SJ-Chris is offline   Reply With Quote
Old 07-23-2021, 05:40 PM   #5
Senior Member
 
Winnebago Owners Club
Carolina Campers
Join Date: Sep 2019
Location: NC
Posts: 140
The next thing I would check would be cleaning the carb. I have not done it on that generator but I have on another, the needle can get clogged. Past that, I am done .
__________________
GrantR
Itasca Ellipse
Silverado Duramax Toad
GrantR is offline   Reply With Quote
Old 07-23-2021, 06:00 PM   #6
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,647
If we had this at our shop, the first thing we would do is loosen the gas line at the carburetor. Try starting and check for fuel spray. If no fuel, loosen the rubber fuel line, before the fuel pump, put the hose in a can of fuel. Try starting. If it starts you have a bad fuel line. If it still shows no fuel you have a bad fuel pump. If you have have fuel, next remove the air cleaner and spray fuel in intake while cranking. If it starts you have a bad carburetor.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 07-23-2021, 11:02 PM   #7
Member
 
Join Date: Sep 2017
Posts: 99
Still not working...here's an update on what I've tried/checked...

To troubleshoot so far here is what I have done to no avail...
- I have a full tank of gas in the motorhome.
- The motorhome is level.
- Altitude adjustment set to 0 (I am near sea level).
- I checked the oil to make sure there wasn't too much (it is to the low end on the dipstick as most seem to recommend).
- I swapped in a good spark plug to make sure that wasn't the problem, and it didn't fix it.
- I checked the air filter and it seems fine (...even tried starting it without the air filter and it didn't start).
- I changed the fuel filter with a new one, primed it and tried starting it several times and that didn't fix the problem.
- I disconnected all the batteries (and my solar) per someone's suggestion to "reset" the generator. Hooked everything back up and it still didn't fix the problem.

Latest items:
- I removed the fuel line going to the carb and tried to start to see if it was sending fuel to the carb. Yes, plenty of fuel is getting pumped to the carb (so it's not a bad fuel pump).

- Compression check: I've never done this before but I think I did it right. Tough to get at the spark plug hole to screw in the compression check tool but I believe I did get it in there and snug. When I cranked it I got ZERO COMPRESSION registering on the tester. I tried it more than once, disconnecting the tester and then putting it back on and making it snug. Zero compression.

So....what does Zero Compression indicate on this generator and what would you recommend my next steps be?

Summary:
- Yes there is fuel going to the carb.
- Yes the spark plug is sparking.
- No, there is not any compression (...unless I did the test wrong).

Thanks in advance!
Chris
SJ-Chris is offline   Reply With Quote
Old 07-24-2021, 11:12 AM   #8
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 858
Sorry to hear all this, you are just going to have to pull gen.. get it on spare tire.. pull it out where you can work safely on it.. hook up a good battery and do another compression test.. or bring it down on jack enough to run compression test again.. if zero then get it on the bench.. pull the heads and see what's going on.. but 1st I just remembered.. do you have a camera scope.. you can snake it gently in spark plug hole and see if piston moving.. or old style was to put finger just over the hole and feel for compression.. I have done that so many times I can tell you within 10pounds , don't put finger in the hole.. just over it..you can lose your finger if you put it in.. so try a bore scope.. keep us posted
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Old 08-05-2021, 06:20 PM   #9
Member
 
Join Date: Sep 2017
Posts: 99
Update: I reached the end my my troubleshooting abilities, so I brought it to my local RV mechanic. After quickly testing that it wasn't something simple, he removed the generator from the RV so he could remove the cover and dive in deeper. Long story short...he tells me the motor is shot. He thinks it must have overheated and some of the internals went ka-put (....he rattled off some internal components that had broken/etc that I didn't jot down). He tried replacing one item and put it back together but was still getting zero compression. He says it would probably cost more money to try to fix this one and it is time for a new generator...

He recommended I find a good used one if I can find one with a warranty. I liked his recommendation as I felt like he wasn't just trying to gouge me for more $$$ and he wasn't pushing me to go out and get a brand new generator.

I wanted to get some opinions from those of you out there who care to share....

This RV is a 2015 Thor Majestic 28a. Previous Cruise America rental. I've been very pleased with it so far (and I have another identical one). They serve well for how I am using them. This one has 140,000 miles on the engine. I can easily see holding on to this one for another 3-5 years. Everything else seems to be in good shape. Would you buy a brand new Onan 4000 generator and install it? Would you go for a used one for less than 1/2 the price?

I did some googling. There are two used ones locally each for ~$800. If I'm going to buy used, I will require seeing that it runs.

I also found these new ones...
https://www.norwall.com/products/Cum...xoCXDkQAvD_BwE

https://www.norwall.com/products/Cum...xoCXDkQAvD_BwE

and I'm sure I can find others. Seem like new ones cost ~$3300-3500.

Does anyone know of any companies out there who rebuild/refurbish Onan generators and sell them with warranties?

I'm not opposed to buying a brand new one. Just weighing my options and looking for opinions (which often times can be valuable and lead to discovery of additional options).

Thanks in advance!
Chris
SJ-Chris is offline   Reply With Quote
Old 08-05-2021, 06:36 PM   #10
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 858
Call Visone.RV at 606 843 9889 or go online.. also eBay for short block.. or small eng warehouse.. only if you are mechanically inclined... only pays if you do the work because shop labor is so hi.. better to buy a new gen.. if you buy a new gen.. try to upgrade to more features like auto start and idle control.. and bigger unit.. try to get one with external oil cooler.. why? Because think about it.. it's 100 outside and you need it 24/7 .. so they burn up.. 99% of time mis used.. good luck and let us know what you did and maybe better members then me will help you
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Old 08-18-2021, 08:18 PM   #11
Member
 
Join Date: Sep 2017
Posts: 99
interesting update...generator fixed

Update: Generator FIXED...here's what was wrong....


So my local RV mechanic had told me that the engine on the generator was done and that it doesn't make sense to replace the engine on these Onan 4000 generators (...I've actually heard that from a couple of knowledgeable mechanics). My options were to buy a new one or a used one.


While investigating buying new, I learned that it would cost ~$4000 shipped for a new Onan 4000 generator (which I was okay with) BUT it would take somewhere between 10-29 weeks to deliver. There is a big parts/component shortage causing huge delays. I didn't like the idea of waiting. So I started looking for a used Onan 4000 generator. I quickly found out that there weren't really very many options. I found a couple locally, but the owners could never get back to me with answers to my basic questions and they seemed flakey.



Then I feel like I lucked out....I found a guy who is retired and now seems to have a passion for rebuilding/refurbishing RV generators. Sounds like he's done dozens and dozens of them over the last 10 years. Incredibly knowledgeable. He had an Onan 4000 that he just finished refurbishing that I could buy for $1700 that was fully tested and operating to spec (and he could demonstrate happily). He also offered to help install it into my RV with my help. I felt like I struck gold finding this guy and made arrangements to visit him (...he was a couple hundred miles away, but I could turn it into a mini-vacation and visit a friend of mine who happened to live nearby). He also insisted, "Let's take a quick look at your current non-running generator and see if we can fix it...that way you won't need to buy this refurbished one." You can tell a lot about the guy's character right there...he wasn't just trying to sell me his latest refurbished generator.


So I visited him on Monday. He asked me if I wanted to just drop it off, or if I was interested in learning more about these generators and I could troubleshoot it with him. He is a bit of an old-timer and I could see that he probably would enjoy some company. And, Since I'm always looking to learn, I stuck around. After about 2 hours he was able to identify what the problem was and he declared, "I can fix this generator for you!".



Here's what the problem was....(Please excuse me if I mis-name any components in my description...I'm not a mechanic)... Once he removed the carburetor he could see the throttle plate (flap) on the carburetor had broken free and was forced downstream and he thinks it might have been wedged in a way that was holding the valve open (hence no compression). We found the throttle plate lodged in that region. There are 2 screws that hold that plate on and they were missing (...presumably they went through the engine). We pulled the cylinder head/cover to inspect the piston and the chamber and you could see on the piston there were some marks/scuffs, but the chamber looked great with no damage. He said my carb looked beyond repair, but he had replacement/rebuilt carbs. He told me he was highly confident that he could quickly refurbish my generator, replace the carb, replace anything else needed while he was in there, do a valve job, etc. He is the kind of guy who could probably rebuild this generator with his eyes closed, AND he took great pride in his workmanship and wanted to make sure when he was done fixing the generator it would be at factor spec/tested and working as good as new (he had all necessary equipment/tools and then some). I left to visit with my friend, but he spent 10 hours working on it that day and the next and I came back the next afternoon and we tested it and reinstalled it. I helped out as much as I could with various aspects and enjoyed learning in the process. He even did a little welding on my support brackets because there was some rust that made him uncomfortable on the brackets and now they are super reinforced. Once installed, we tested it again and it is purring like a kitten even under full load.



I am confident this generator will last quite a while now. Out the door cost for parts and ~12 hours of labor: $780. I'm quite pleased!


Happy camping all!
Chris
SJ-Chris is offline   Reply With Quote
Old 08-19-2021, 01:15 PM   #12
Member
 
Join Date: Jul 2021
Posts: 64
I was following your story...what an incredible find with this guy.
I would have loved to be there and see how he explained the generator and the repair.

Congrats on the knowledge gain
__________________
Chris
U.S Navy (Ret)
2017 Majestic 19G
Jimmy Jime is offline   Reply With Quote
Old 08-19-2021, 04:51 PM   #13
Member
 
Join Date: Sep 2017
Posts: 99
Quote:
Originally Posted by Jimmy Jime View Post
I was following your story...what an incredible find with this guy.
I would have loved to be there and see how he explained the generator and the repair.

Congrats on the knowledge gain

Thanks! I learned a lot (...and got my generator repaired/refurbished for a great price). I've got 3 RVs, so whatever I can learn to fix on one, comes in handy when I need to fix one of the other ones!
SJ-Chris is offline   Reply With Quote
Old 08-25-2021, 04:55 PM   #14
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 858
If it's ok with him.. could you post his name.. check with him.. see if you can post his address and even maybe phone number.. we are always in need of great people like him.. so please give him credit if it's ok with him.. and thank you.. I am so glade you got back to us and great story with great ending..
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Microquiet 4000, cranks but no start Redfishman RV Systems & Appliances 8 09-23-2019 06:05 AM
Onan generator cranks but won't turn over pbascom RV Systems & Appliances 7 04-24-2016 07:51 AM
Onan generator cranks but wont start Starhead Class A Motorhome Discussions 9 02-29-2016 08:29 PM
Engine cranks stops after 4 cranks, no start long53 Workhorse and Chevrolet Chassis Motorhome Forum 26 07-21-2015 09:18 PM
Cat cranks but won't start VanDiemen23 Caterpillar Engine Forum 10 10-31-2013 12:40 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.