Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-03-2009, 12:41 PM   #1
Junior Member
 
Join Date: Jul 2009
Posts: 1
Question Onan Will Not Start

2006 Onan Micro Quiet 3600 LP in my 06 Winnebago View.

Unit cranks strong but will not start. Propane is topped off. If anyone has any suggestions on where to start troubleshooting it would be greatly appreciated.
drchiro is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-04-2009, 03:22 AM   #2
Moderator Emeritus
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,061
There is a breather tube for the LP regulator that drops down and is accessable from under the coach. Check to be sure a mud-dobber or other pest has not built a nest in it. Clean it out if they have and retry starting.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 07-04-2009, 09:27 AM   #3
Senior Member
 
DandS's Avatar
 
Newmar Owners Club
Ford Super Duty Owner
Join Date: Jun 2009
Location: West Michigan
Posts: 920
Main causes are usually either fuel or spark related. In my case, with simialar symptoms, I had a plug wire chewed in half by a critter.
__________________
Dave
2010 Canyon Star 3647
2010 Ford Escape
DandS is offline   Reply With Quote
Old 07-04-2009, 09:34 AM   #4
Senior Member
 
Roam America's Avatar
 
Texas Boomers Club
Join Date: Jan 2000
Location: Somewhere in the lower 48
Posts: 2,300
Does your start/stop switch display a code in the form of the light blinking? The light blinks a certain number of times like once, twice, etc. The Onan manual has a table with the # of blinks and the likely cause. EX: If the gen is low on oil it will crank but not start and that has a certain [blinking] code.

I too had a critter issue. Mine would start and run as long as I held the switch in the start position. As soon as I let go, the gen dies. Critters chewed a wire off in the start circuitry. In this case the light did not blink at all. The gen just stopped.


BTW - welcome to iRV2.com. We all hope you continue to visit with us and share your experiences.
__________________
John, Joyce and Zoie (our 17# Guard Dog)
2018 Ford F-450 KR / 2019 Mobile Suites 40KSSB4
Fulltiming since 2008 and loving it
Roam America is offline   Reply With Quote
Old 08-04-2009, 07:14 PM   #5
Member
 
Join Date: Sep 2008
Location: Bradenton, FL
Posts: 44
Onan Propane 6kw Generator - Misfiring Help Me Diagnose

Team,

Ok, I have an Onan Propane Generator, 6KW I believe. Anyway, we just got back from a trip this week to Flagler Beach, FL - just South of St Augustine (East Coast of FL) - State RV Park right on the beach (highly recommended). Anyway, dash A/C has been out for a while. We traveled 4.5 hrs there using the generator so we had A/C - no problem. We traveled 4.5 hrs back using the generator (a week later) - no problem.

However a day later (today), I finished de-sanding the RV and general clean up. Went to take it back to its storage spot, started the engine and the generator - as I did earlier. The generator started then stopped, but when re-started it started these loud popping noises.... backfiring (I think). It would run but pop loudly two to three times a second, then run smooth for 5 seconds or so (it was intermittent). It would finally accept a load on the engine strong enough to put out power, but it wasn't constant. As I inspected the engine, when it would make this pop, I would feel air coming out from the air filter intake.

I did change the plugs and oil a couple of weeks ago. So I know it has plenty of oil and new plugs. I have not yet pulled the plugs to see if they are fouled so much to impact firing, but like I said ran like a dream yesterday for almost 5 hours. The oil is at the proper level. I also refilled the propane tank wondering if maybe it was low, but was going to do that anyway.

Any ideas??????????????

Any suggestions on where I can get good info on troubleshooting. By the way this is a 1996 Gulfstream Scenic Cruiser with the generator only having about 450 hrs on it.

Thanks as always.

Brian Kelly
__________________
__________________
Brian
1996 Gulfstream Scenic Cruiser 36' Class A
Spartan Alpine Chassis - Owned since 2006
RBAJJK is offline   Reply With Quote
Old 11-11-2013, 03:40 PM   #6
Member
 
pmcsurf1's Avatar
 
Join Date: Nov 2012
Location: St. Augustine FL
Posts: 78
Quote:
Originally Posted by RBAJJK View Post
Team, Ok, I have an Onan Propane Generator, 6KW I believe. Anyway, we just got back from a trip this week to Flagler Beach, FL - just South of St Augustine (East Coast of FL) - State RV Park right on the beach (highly recommended). Anyway, dash A/C has been out for a while. We traveled 4.5 hrs there using the generator so we had A/C - no problem. We traveled 4.5 hrs back using the generator (a week later) - no problem. However a day later (today), I finished de-sanding the RV and general clean up. Went to take it back to its storage spot, started the engine and the generator - as I did earlier. The generator started then stopped, but when re-started it started these loud popping noises.... backfiring (I think). It would run but pop loudly two to three times a second, then run smooth for 5 seconds or so (it was intermittent). It would finally accept a load on the engine strong enough to put out power, but it wasn't constant. As I inspected the engine, when it would make this pop, I would feel air coming out from the air filter intake. I did change the plugs and oil a couple of weeks ago. So I know it has plenty of oil and new plugs. I have not yet pulled the plugs to see if they are fouled so much to impact firing, but like I said ran like a dream yesterday for almost 5 hours. The oil is at the proper level. I also refilled the propane tank wondering if maybe it was low, but was going to do that anyway. Any ideas?????????????? Any suggestions on where I can get good info on troubleshooting. By the way this is a 1996 Gulfstream Scenic Cruiser with the generator only having about 450 hrs on it. Thanks as always. Brian Kelly __________________
Did you ever find a good service spot in st Augustine? I'm wondering who I can trust.
__________________
2014 Thor Palazzo 36.1Toad 1996 Civic
Boat 25' Carolina Skiff
pmcsurf1 is offline   Reply With Quote
Old 11-11-2013, 06:04 PM   #7
Senior Member
 
Rocky Larson's Avatar
 
Workhorse Chassis Owner
Join Date: Aug 2007
Posts: 849
Quote:
Originally Posted by drchiro View Post
2006 Onan Micro Quiet 3600 LP in my 06 Winnebago View.

Unit cranks strong but will not start. Propane is topped off. If anyone has any suggestions on where to start troubleshooting it would be greatly appreciated.
Check oil level. They will not start/run if too low.
__________________
Jan and Rocky
Volunteers USFWS. 9,300 hrs each, 29 refuges. 04 Allegro 30DA, WH 8.1, Banks, 2012 Jeep Liberty , Brake Buddy Adv Select, 300watts Solar, "Philippians 4:11-13 KJV"
Rocky Larson is offline   Reply With Quote
Old 11-12-2013, 03:41 PM   #8
Senior Member
 
Chuck48's Avatar
 
Join Date: Mar 2012
Posts: 154
Don't know if this will help or not. On my old Onan 6.5 gas, if it shut off because of temperature or low oil, you had to hold down the stop button for a few seconds to reset unit then it would start. Worth a shot. Good luck!
Chuck48 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
6.5 Onan Generator won't start cadteach MH-General Discussions & Problems 1 06-22-2009 12:07 AM
Onan Generator Won't Start musikfans MH-General Discussions & Problems 5 08-13-2008 03:56 AM
Onan Generator Quits On Start With No Load Birddog Pilot Alpine Coach Owner's Forum 26 08-11-2008 11:49 AM
onan auto start Stubborn Newmar Owner's Forum 3 03-03-2008 03:37 PM
My Onan 4.0 won't start, HELP! twinbubba Toy Haulers Discussion 8 04-25-2007 09:50 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.