Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-09-2018, 04:13 PM   #1
Junior Member
 
Join Date: Aug 2018
Posts: 6
Slides and Leveling Jacks won't respond

Hi All,

We have a 2006 Itasca Ellipse 40KD Motorhome with hydraulic slides and leveling jacks that will not respond.

When pushing the slide in button you can hear a slight click but no response from any slide. Leveling Jacks will not go up or down.

We have added 2 quarts of hydraulic fluid, have manuals but cant find the fuse. Took chassis batteries and had them checked but they were good. Tried the battery boost but that didnt help.

Any ideas?

Thanks
Ginny
Fiishergurl is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-09-2018, 04:55 PM   #2
Senior Member
 
Join Date: Feb 2017
Location: Denver, CO
Posts: 1,038
Our Class A has to have the parking brake applied before either of those systems work. Is yours the same way?
BirchyBoy is offline   Reply With Quote
Old 09-09-2018, 04:58 PM   #3
Senior Member
 
Ernie.'s Avatar
 
Join Date: Feb 2009
Location: Smithton, IL
Posts: 2,947
look for a circuit breaker in line near your house batteries, might have a round pop-up button or a flag arm that pivots out. had it happen to me, also generator wouldn't crank.
__________________
Ernie and Shirley
2019 Dutch Star 4363 Freightliner
2020 Lincoln Nautilus
Ernie. is offline   Reply With Quote
Old 09-09-2018, 05:17 PM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 23,650
If your system is HWH , the main 40 amp fuse on my system was within a foot of the pump/solenoid. Inline.

Mine looked like this; photo below;, lit up the control pad , but wouldn't pass enough power to operate anything.

If I have a picture showing location I'll post it.

EDIT: If you added fluid , when the jacks were extended , it will spill out as they retract, and overfill the reservoir..

Re-edit ; second photo ; zip tie; shows the location where the fuse was and I installed a 12 volt circuit breaker.
Attached Thumbnails
Click image for larger version

Name:	IMG_0277 (640x360).jpg
Views:	39
Size:	102.9 KB
ID:	218381   Click image for larger version

Name:	IMG_0308.JPG
Views:	44
Size:	115.1 KB
ID:	218383  

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-09-2018, 11:03 PM   #5
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 23,263
You will find a wealth of information on the HWH website, including your owners manual and service information. Be sure to read the entire FAQ page too.
That said, a prominent member here is "azpete" he works for HWH and offers his advice and knowledge freely to help other members. Use the search box at the top of the page to locate one of his posts, then send him a PM by clicking on his screen name.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 09-09-2018, 11:59 PM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 23,650
Ginny; if your slide drive leveling system isn't HWH, please add that info to your post , as a few of us could be barking up the wrong tree .
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-10-2018, 05:28 AM   #7
Senior Member
 
veraken's Avatar


 
Monaco Owners Club
Vintage RV Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2012
Location: Lexington, SC
Posts: 2,245
If your system is HWH, contact Paul at AZPETE on the Irv2 forum. He works for HWH and can answer your questions. His email is pfmaddox@att.net and his phone number is 602-549-3638. He is a Commercial Member and has posted that his phone is always on, and if not answered, leave a message.

He has helped other on this forum and I am sure he can help you
__________________
Vera & Ken
1998 Holiday Rambler Imperial, RR8S Chassis
Cummins 6C8.3 mechanical engine, 325HP, 3060 Allison
Towing 2014 Ford Explorer
veraken is offline   Reply With Quote
Old 09-10-2018, 06:06 AM   #8
Junior Member
 
Join Date: Aug 2018
Posts: 6
Quote:
Originally Posted by Skip426 View Post
Ginny; if your slide drive leveling system isn't HWH, please add that info to your post , as a few of us could be barking up the wrong tree .
Thank you everyone for the advice. Yes it is HWH. Going to check some of the things you all mentioned and will update later.

Thanks again,
Ginny
Fiishergurl is offline   Reply With Quote
Old 09-12-2018, 09:21 AM   #9
Senior Member
 
Join Date: Jun 2016
Posts: 190
Purely a FYI consideration, but when our hydraulic slide wouldn't come in on our 5er about 17 years ago, those "supposedly in the know more than us", kept adding hydraulic fluid.

Finally when I went into the bedroom with bare feet I felt a wet carpet and huge stench of the fluid = turned out that manufacturers had put the hose under the bed slide out and over time with it going in and out had created a hole in the tubing = just saying in case it's none of the above, might be worth checking any bad placement caused by friction as was our case.
SoonToBeFT is offline   Reply With Quote
Reply

Tags
jacks, leveling, leveling jacks, slide



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stabilizer Jacks won’t respond. flwrpeg1 iRV2.com General Discussion 5 07-24-2018 07:42 AM
Help! Blinds won't respond ikold Entegra Owner's Forum 11 08-28-2016 09:03 AM
Jacks down then slides or slides then jacks down? Yolo72 Entegra Owner's Forum 10 01-29-2013 08:13 PM
Leveling jacks don't respond! artro MH-General Discussions & Problems 7 03-04-2006 07:02 AM


All times are GMT -6. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.