Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2013, 04:48 PM   #1
Senior Member
 
gauto5150's Avatar
 
Join Date: Apr 2011
Location: Northwest Indiana
Posts: 326
Splendide 2000s washer/dryer

I'm wondering if anyone else has experienced the problem I'm having with my combo washer/dryer.
This problem just showed up unexpectedly, no symptoms or signs up to this point.
The wash cycle runs normal, once it reaches the drying cycle it starts as it normally does as well. It rotates and you hear the heating element click on and then reverses direction for about a minute or two.
Then the wash selector dial rotates by itself all the way around to the RESET area located about 12 o'clock and shuts down.
This happens regardless of the time selected for the dryer and regardless of what wash cycle you choose. I've tried to use JUST the dryer and it does the same thing.
There is nothing listed in the manual troubleshooting section (I didn't think it would).
Has anyone run into this problem before?
__________________
2004 Fleetwood Discovery 3126 CAT engine
gauto5150 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-13-2013, 05:02 PM   #2
Senior Member
 
docj's Avatar
Official iRV2 Sponsor
 
Join Date: May 2011
Posts: 7,832
The newer 2100 series Splendide's have a common dryer fault mode in which crud gets on some sensor and a particular set of lights flash. Your problem sounds sort of similar but the fix we use for that wouldn't work with you non-electronic model.

However, all the Splendide service documents are located on this website: Splendide Combo Washer Dryer Technical Education Site
Hopefully, you'll be able to read through the service info for your model and determine the cause.
__________________
Joel (AKA docj)--
RV Technology Specialist
docj is offline   Reply With Quote
Old 10-13-2013, 05:57 PM   #3
Senior Member
 
gauto5150's Avatar
 
Join Date: Apr 2011
Location: Northwest Indiana
Posts: 326
Quote:
Originally Posted by docj View Post
The newer 2100 series Splendide's have a common dryer fault mode in which crud gets on some sensor and a particular set of lights flash. Your problem sounds sort of similar but the fix we use for that wouldn't work with you non-electronic model.

However, all the Splendide service documents are located on this website: Splendide Combo Washer Dryer Technical Education Site
Hopefully, you'll be able to read through the service info for your model and determine the cause.
Thanks I'll dig into that manual.
__________________
2004 Fleetwood Discovery 3126 CAT engine
gauto5150 is offline   Reply With Quote
Old 10-15-2013, 08:45 AM   #4
Senior Member
 
Damon Owners Club
Join Date: Jul 2010
Location: Annapolis,MD
Posts: 1,453
Sounds to me that you may have an accumulation of lint in
the outer tub. This reduces the air flow, check your vent flap
for reduced flow.
Call them, they have a simple protocol for this
common problem. It worked for me.
Mac99 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.