Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-13-2014, 05:27 PM   #1
Junior Member
 
Join Date: Oct 2013
Location: Gallatin Gateway, MT
Posts: 13
Question Suburban Water Heater Noise

I have a Suburban SW12DE water heater that is making a loud hum or squeal when any of the hot water faucets are opened. It continues as long as the water is running. At first It seemed that one of the check valves was faulty. Both of the valves have been replaced twice, but has not fixed the problem. The noise is not present when the heater bypass valve is opened and the water bypasses the heater. All of the water lines have been checked without any problems being detected. It seems that the noise is definitely coming from the heater. Any thoughts or suggested cures are welcomed.
bleman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-13-2014, 05:42 PM   #2
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 9,094
Lost you air bladder....

Quote:
Originally Posted by bleman View Post
I have a Suburban SW12DE water heater that is making a loud hum or squeal when any of the hot water faucets are opened. It continues as long as the water is running. At first It seemed that one of the check valves was faulty. Both of the valves have been replaced twice, but has not fixed the problem. The noise is not present when the heater bypass valve is opened and the water bypasses the heater. All of the water lines have been checked without any problems being detected. It seems that the noise is definitely coming from the heater. Any thoughts or suggested cures are welcomed.
Shut off all water supply's, drain your hot water tank, then turn the water back on and fill it back up, crack a faucet to bleed air out(A small air bladder will remain inside the tank) and see if this fixes your problem. Water heaters need an air pocket at the top in order for the water to expand slightly when heated--if no expansion room, the popoff will leak to let pressure off. And the air pocket forms normally when the tank is filled from either city water or the water pump.
__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 01-13-2014, 06:06 PM   #3
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
I'd be curious to know if that fixes the noise. I've heard it on a few trailers but no one complained so I never fixed it.
jesilvas is offline   Reply With Quote
Old 01-14-2014, 04:34 PM   #4
Junior Member
 
Join Date: Oct 2013
Location: Gallatin Gateway, MT
Posts: 13
I drained the tank as suggested and refilled it by cracking the valve in the sink. The problem noise (steady squeal) is still evident. Of interest the same squeal was present while the tank was filling. I checked the cold water inlet and check valve and all seem OK. Is there something in the tank at the cold water inlet that could be causing the problem? This is a fairly new tank in a 2012 Mobile Suites. Thanks
bleman is offline   Reply With Quote
Old 01-14-2014, 05:20 PM   #5
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Are you sure it's not the T&P valve making the noise? If the seal was compromised it may allow air in or out causing a squealing.
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 01-14-2014, 06:48 PM   #6
Junior Member
 
Join Date: Oct 2013
Location: Gallatin Gateway, MT
Posts: 13
The T & P Valve was also replaced with the 2nd set of check valves. It is new also. I am stumped!
bleman is offline   Reply With Quote
Old 01-15-2014, 04:13 AM   #7
Senior Member
 
Join Date: Nov 2005
Posts: 3,977
Could part of a defective flow valve that was already replaced still be stuck in a water line somewhere?
__________________
Neil V
2001 Winnebago Adventurer WFG35U
NeilV is offline   Reply With Quote
Old 01-16-2014, 02:27 PM   #8
Junior Member
 
Join Date: Oct 2013
Location: Gallatin Gateway, MT
Posts: 13
The original check valves that were replaced were not at fault. Inspection of the valves showed that they were OK (no missing parts).
bleman is offline   Reply With Quote
Reply

Tags
heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water heater bypass salem13 Forest River Owners Forum 5 08-17-2014 03:07 PM
Water Heater Question-Extra Valve? DRKM RV Systems & Appliances 5 12-07-2013 08:37 AM
Suburban heater tail pipe rust Magumba RV Systems & Appliances 2 11-26-2013 05:37 PM
Bounder: 2003 Bounder hot water heater wpitts1368 Fleetwood Owner's Forum 6 08-06-2013 05:43 PM
Atwood & Suburban water heaters & Furnace "007" RV Systems & Appliances 1 08-07-2010 10:37 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.