Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-09-2009, 03:45 PM   #1
Member
 
RobG's Avatar
 
Join Date: Jul 2000
Location: Mesa, AZ
Posts: 94
I live in my 5th wheel fulltime, and now my water heater won't light. Camping World doesn't have any techs on weekends, the only time I'm free to go down there, so I'm up a creek at the moment.

It's a Suburban SW12DE on a 2006 Keystone Raptor. It was working fine until I went home to Reno for two weeks over Christmas (I left the trailer here in San Jose). I came back, and it heated the tank once, but not since.

Whenever it attempts to light, I get the red RESET light. So I flip it off and back on. Red light. It'll try to light, you hear the clicking, and nothing. Tries three times and gives up.

An hour ago, I was seeing a flame, but it was still giving up after three tries. I shut off the water and drained the tank so I could double-check the annode rod, and it's fine, still lots of it left. So I put it back, refilled the tank, and tried again. Now I get no flame at all, and I don't smell propane either. This is regardless of whether it's set to gas or electric mode.

The manual that came with it is worthless for troubleshooting. The reset switch on the heater itself doesn't appear to do anything (the two buttons behind the rubber "plate").

Any ideas on what I can try?

Thanks!

Rob
__________________
2019 Arctic Fox 992 Truck Camper
2006 Keystone Raptor 3814SS
2005 Dodge RAM 3500 QC 4x4 6sp
RobG is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-09-2009, 03:45 PM   #2
Member
 
RobG's Avatar
 
Join Date: Jul 2000
Location: Mesa, AZ
Posts: 94
I live in my 5th wheel fulltime, and now my water heater won't light. Camping World doesn't have any techs on weekends, the only time I'm free to go down there, so I'm up a creek at the moment.

It's a Suburban SW12DE on a 2006 Keystone Raptor. It was working fine until I went home to Reno for two weeks over Christmas (I left the trailer here in San Jose). I came back, and it heated the tank once, but not since.

Whenever it attempts to light, I get the red RESET light. So I flip it off and back on. Red light. It'll try to light, you hear the clicking, and nothing. Tries three times and gives up.

An hour ago, I was seeing a flame, but it was still giving up after three tries. I shut off the water and drained the tank so I could double-check the annode rod, and it's fine, still lots of it left. So I put it back, refilled the tank, and tried again. Now I get no flame at all, and I don't smell propane either. This is regardless of whether it's set to gas or electric mode.

The manual that came with it is worthless for troubleshooting. The reset switch on the heater itself doesn't appear to do anything (the two buttons behind the rubber "plate").

Any ideas on what I can try?

Thanks!

Rob
__________________
2019 Arctic Fox 992 Truck Camper
2006 Keystone Raptor 3814SS
2005 Dodge RAM 3500 QC 4x4 6sp
RobG is offline   Reply With Quote
Old 01-09-2009, 03:52 PM   #3
Administrator in Memoriam
 
Hitchhiker's Avatar


 
Appalachian Campers
Join Date: Jan 2000
Location: Buladean, NC
Posts: 8,126
Have you verified an adequate supply and pressure of your propane by lighting the cook stove burners or running the furnace? Sometimes the OPD valve on a propane tank will stick closed thus preventing the gas flow.
__________________
'11 GMC Acadia SLT AWD
'11 GMC Sierra 1500 4x4 Extended Cab
Hitchhiker is offline   Reply With Quote
Old 01-09-2009, 04:02 PM   #4
Member
 
RobG's Avatar
 
Join Date: Jul 2000
Location: Mesa, AZ
Posts: 94
Gas supply is good. I just lit a burner, it works well. I also ran the fridge on propane for about ten minutes with no problems.

I got out my compressed air and made sure the tube (the one that goes 90 deg into the burner area) was free of obstruction, and it is. It's now back to where I get a flame in the tube, just off of the gas outlet, but it doesn't make it into the burner area.

Rob
__________________
2019 Arctic Fox 992 Truck Camper
2006 Keystone Raptor 3814SS
2005 Dodge RAM 3500 QC 4x4 6sp
RobG is offline   Reply With Quote
Old 01-09-2009, 04:25 PM   #5
Member
 
RobG's Avatar
 
Join Date: Jul 2000
Location: Mesa, AZ
Posts: 94
Followup...

I was reading through the instruction manual again. As near as I can tell from reading it, the electric element works independently of the gas burner. But what I don't understand is if its little on/off switch makes it go on only when the main switch is on, or is simply always on if it's set to ON and there's 110V available?

As long as the electric element is working, I'll have hot water while figuring out why the gas half of it doesn't work.

The other thing is I can't tell from the book what the red light next to the main switch means exactly. It says RESET above it.

In the past, I would turn on the main, and that light never came on. The water heater simply worked. Now, the light is on the instant I turn the main switch on. Hmmm.

Rob
__________________
2019 Arctic Fox 992 Truck Camper
2006 Keystone Raptor 3814SS
2005 Dodge RAM 3500 QC 4x4 6sp
RobG is offline   Reply With Quote
Old 01-09-2009, 04:38 PM   #6
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 27,312
The 120VAC heating element is completely independent of the propane burner. Turn it on(insure the tank is full first) and it should provide plenty of hot water. BTW, my RV has 2 switches for the electric heater element, one is the 15A breaker in the main electrical panel, the other is behind the outside access panel.This website may help with your propane burner issue. That red "reset" light could also be a push button to reset the control board.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 01-09-2009, 04:58 PM   #7
Member
 
RobG's Avatar
 
Join Date: Jul 2000
Location: Mesa, AZ
Posts: 94
How long does it take the 120v element to heat? I ran the hot water side of the fawcet a few minutes ago and it was still ice cold.

The red light isn't a button unfortunately.

What I'm afraid of is that the high-temp circuit is bad. The reset buttons don't do anything to fix it. But if so, then the electric element won't work either.

I just left a message with an RV service place here in San Jose. But odds are they aren't open weekends so I'm SOL until next week.

Why is it this stuff ONLY happens on weekends??

Rob
__________________
2019 Arctic Fox 992 Truck Camper
2006 Keystone Raptor 3814SS
2005 Dodge RAM 3500 QC 4x4 6sp
RobG is offline   Reply With Quote
Old 01-09-2009, 05:18 PM   #8
Administrator in Memoriam
 
Hitchhiker's Avatar


 
Appalachian Campers
Join Date: Jan 2000
Location: Buladean, NC
Posts: 8,126
The red light is supposed to be on if the water heater doesn't light. Hence, it's telling you to 'reset' when it's lit.

Insects love to get into a water heater's gas line, make sure it's clear of spider webs and stuff like that.
__________________
'11 GMC Acadia SLT AWD
'11 GMC Sierra 1500 4x4 Extended Cab
Hitchhiker is offline   Reply With Quote
Old 01-09-2009, 06:58 PM   #9
Member
 
RobG's Avatar
 
Join Date: Jul 2000
Location: Mesa, AZ
Posts: 94
I think I got the gas side of it working.

Thinking about how the flame didn't seem "focused" the few seconds it was on, plus Richard's remark about crap in the gas line, and I decided to remove that little loopy-loop gas line that runs from the gas valve to the tube that leads into the burner.

It looked like there was a white "crust" in the end of the line, though not sure how anything would get in there. But anyway, I washed it out with Simple Green and water, then used compressed air to dry it. Reinstalled, and BINGO, the burner lit.

BUT, that tells me my electric element probably doesn't work. Call it a hunch, but I bet the dealer burned out the element by switching the thing on without water in the tank. I'll have to see about getting it checked and replaced.

Thanks for the help!!

Rob
__________________
2019 Arctic Fox 992 Truck Camper
2006 Keystone Raptor 3814SS
2005 Dodge RAM 3500 QC 4x4 6sp
RobG is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suburban Water Heater Question Rnicfingrp Newmar Owner's Forum 14 01-13-2009 12:41 PM
Question Suburban 10 Gal Water Heater Park Gulf Stream Owner's Forum 5 11-16-2008 04:29 AM
Powerline EMS - Water heater light will not light rv rick Winnebago Industries Owner's Forum 9 10-14-2008 04:20 PM
Anode For Suburban Water Heater Shanwick RV Systems & Appliances 5 05-15-2008 06:10 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.