Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-17-2022, 08:27 PM   #1
Junior Member
 
Join Date: May 2022
Posts: 5
Blog Entries: 1
Surge Guard 34560 caution light

I purchased a new to Class A 2015 Itasca Suncruiser 35P. It came with the Surge Guard 34560 and it worked fine at dealer plugged into 50amp service. I bought a 15amp to 50amp converter and when I plug in at home I get the use cation light blinks red but the line one and line 2 lights were green,I waited for about 10 mins and pulled the plug. I’m only guessing but was wondering/thinking was it blinking because I was plugged in at home using adapter and RV wasn’t getting enough power? Thank you in advance for you help.
Litchy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-17-2022, 09:10 PM   #2
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 7,304
I have the same model and occasionally it seems the transfer timer fails to transfer in a timely manner, when this happens I disconnect it wait a few seconds and reconnect.
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L w/ 400 watts solar 420Ah LiFePo4
2017 Jeep Cherokee Overland & 2007 Toyota Yaris TOADs with Even Brake,
Demco Commander tow bar and Blue Ox / Roadmaster base plates
Isaac-1 is online now   Reply With Quote
Old 05-19-2022, 09:42 PM   #3
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 21,739
Surge Guard 'looks' at Voltage not Amperage so 15a, 20a, 30a or 50a isn't the issue

Surge Guard could be indicating:
Reverse Polarity (hot & neutral wiring reversed)
Faulty Ground

What style of 50A to 15A adapter are you using?
Puck type or Dogbone
*issue is either within the Outlet you are plugging into
your shore power cord
the adapter

Can you try another outlet?
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Old 05-20-2022, 05:21 PM   #4
Junior Member
 
Join Date: May 2022
Posts: 5
Blog Entries: 1
It’s a dog bone type. I haven’t tried any other outlets yet.
Litchy is offline   Reply With Quote
Old 05-20-2022, 10:17 PM   #5
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 21,739
Test the Outlet for proper wiring
Neutral slot should not be HOT
*Neutral to Ground (wide slot to round hole)

Tests correct....plug in just that adapter and check the Neutral to Ground
*bottom Slot to Top round hole
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SURGE GUARD PROTECTION - on Tiffin Progressive vs Surge Guard? JimLuk Tiffin Owner's Forum 17 12-24-2020 09:36 PM
Anyone with experience for a "Surge Guard 34560" 99dart Class A Motorhome Discussions 33 10-10-2020 07:21 AM
TRC Surge Guard 34560 Delay Fault? Isaac-1 RV Systems & Appliances 0 09-01-2017 04:32 PM
Surge Guard 34560 Trips at night Freightguy RV Systems & Appliances 6 08-20-2014 03:45 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.