Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-11-2014, 12:10 AM   #1
Junior Member
 
Join Date: Apr 2014
Posts: 3
Thetford Aqua Magic IV - Need Help with Blade Position

Today I pulled out and took apart my Thetford Aqua Magic IV Toilet. I did this with the intent of replacing the blade and seal. However, as soon as I had it apart the blade had fallen off the actuator assembly. Now I donít know how the blade sets back on as it is not a "only one way" fit.
I have the manual but it doesnít really display the position of the blade clearly enough for me to see exactly how it fits on.
Any pictures/good diagrams/good illustrations/references or clear instructions would be appreciated.
XCentrick is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-11-2014, 05:58 AM   #2
Senior Member
 
trackman's Avatar
 
Join Date: Oct 2011
Posts: 1,136
Go to google and type in "Images Thetford Aqua Magic IV toilet"
trackman is offline   Reply With Quote
Old 06-12-2014, 09:27 PM   #3
Junior Member
 
Join Date: Apr 2014
Posts: 3
Thetford Aqua Magic IV - Need Help with Blade Position

Thanks for the Google search. It helped a lot. I got the toilet back together today.
XCentrick is offline   Reply With Quote
Reply

Tags
ford, need help



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thetford toilet blade seal SLVrver Tiffin Owner's Forum 3 04-11-2014 03:58 PM
Thetford Aqua Magic Timay 5th Wheel Discussion 1 04-06-2014 02:22 PM
Thetford toilet foot pedal broke moldmkr iRV2.com General Discussion 4 04-04-2014 11:31 AM
Aqua Hot stopped working Hobdendw Alpine Coach Owner's Forum 18 01-25-2014 09:51 AM
Thedford Aqua Magic Style Plus Toilet CBChief MH-General Discussions & Problems 4 11-07-2013 03:00 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.