RV Trip Planning Discussions

Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2020, 05:59 PM   #1
Junior Member
 
Join Date: Jun 2018
Posts: 4
2000 DutchStar 8.3 Spartan chassis No start

Recently I purchased a 2000 Dutchstar DP with an 8.3 cummins. It was sold from an insurance auction for having been a victim of a power surge on the house side and blew up a few appliances. It has 74,000 miles and an allison automatic. Air ride suspension.

It drove trouble free 4000 miles to my home in southern Ontario Canada. It will not start. It has no illumination of the transmission selector, no start on the ignition switch. No start of the generator. (ive never had it running)If I jump the starter it will start but not give the the transmission selections. Slides are in. I have checked everything that is obvious from fuses to breakers and replaced the ignition switch. Has good batteries with good clean and tight connections. Starter has been replaced but not while I have owned it. No manuals present. That is the next adventure find diagrams and manuals. Someone cleaned it for the auction and the manuals went in the garbage (I assume)

Any help or advice would be appreciated.

Earl Robinson
Peterborough Canada
__________________

crazyearl is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-30-2020, 07:44 AM   #2
Senior Member
 
jimmy braden's Avatar
 
Texas Boomers Club
Holiday Rambler Owners Club
Join Date: Jun 2002
Location: What? Like right now? ;-)
Posts: 1,176
Quote:
Originally Posted by crazyearl View Post
Recently I purchased a 2000 Dutchstar DP with an 8.3 cummins. It was sold from an insurance auction for having been a victim of a power surge on the house side and blew up a few appliances. It has 74,000 miles and an allison automatic. Air ride suspension.

It drove trouble free 4000 miles to my home in southern Ontario Canada. It will not start. It has no illumination of the transmission selector, no start on the ignition switch. No start of the generator. (ive never had it running)If I jump the starter it will start but not give the the transmission selections. Slides are in. I have checked everything that is obvious from fuses to breakers and replaced the ignition switch. Has good batteries with good clean and tight connections. Starter has been replaced but not while I have owned it. No manuals present. That is the next adventure find diagrams and manuals. Someone cleaned it for the auction and the manuals went in the garbage (I assume)

Any help or advice would be appreciated.

Earl Robinson
Peterborough Canada
So it started several times fine (during refueling) on your trip home?

Sounds like a wire to the ecm. Start with checking for power to the main harness under the drivers seat bay.
__________________

__________________
2003 Scepter 40PDBB - Roadmaster rr8s - Cummins ISC350 - purch aug16
jimmy braden is offline   Reply With Quote
Old 07-01-2020, 06:21 AM   #3
Junior Member
 
Join Date: Jun 2018
Posts: 4
I didn't drive it home. A couple who move RV's across the USA did and reported zero issues. I called Spartan chassis. (great company so far BTW) and the sent me 83 pages of wiring diagrams and all the fuse locations etc. Saturday with diagrams in hand I am heading to the coach to work on it. Spartan says it is in the TCM or in the fuse area of transmission. If it doesn't sense neutral it is a no start. I will update as I go in case anyone else encounters same issue.
crazyearl is offline   Reply With Quote
Old 07-01-2020, 06:51 AM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 22,447
You do need the trans display to light up for it to start.

Some stick a fuse right near the batteries.
twinboat is offline   Reply With Quote
Old 07-01-2020, 08:26 PM   #5
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 19,915
Speaking only of my MH(see below), I had a very similar problem -no power to transmission pad.
Cutting to the chase, the problem was a loose connection on the firewall(outside). There is terminal block where power comes from the chassis batteries and from the terminal block is disseminated to the shift-pad, dash instruments, etc.
It took a mobile mechanic and me 1.5 hrs to find the loose connection, he tightened the retaining nut and everything worked normally, has ever since.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Reply

Tags
chassis, dutchstar, no start, spartan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2019 Dutchstar Spartan chassis have side mounted service Center? Canuck53 Newmar Owner's Forum 56 08-19-2018 05:12 PM
2004 Dutchstar - renovate or upgrade to 2008 Dutchstar? Racing4Fun Newmar Owner's Forum 15 03-26-2018 07:00 PM
Dutchstar DP 2002 Spartan chassis DTRAWFORD Newmar Owner's Forum 12 07-20-2016 07:23 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×