Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-12-2019, 03:09 PM   #1
Junior Member
 
Join Date: Feb 2019
Posts: 2
Onan 5500 Generator runs fine under load shuts off with no load

Good day!
Have an aggravating issue with my Onan 5500 generator, that hopefully someone on here as a solution.

Original problem, would not crank throwing a code 32. Took to a Cummins certified mechanic and had the following work done (drive system rebuilt under warranty, new carb, new rotor, new control board, new pins for switch, new oil and oil filter).. Just a few things.. Now am facing another issue. Unit cranks up well, runs well for a little while under idle, then shuts off. If able to get a load (2 ACs) on it, it will run for about 1 hr. and shut off. If I reduce the load or shut the load off at any point, the generator revs briefly, comes back down and will shut off in about 2 minutes. And unfortunately, the control board is not providing a code, which is stumping us and the mechanic. Help!!
zduffie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-12-2019, 05:42 PM   #2
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 48,190
Welcome to IRV2! We're sure glad you joined the gang!

Sorry I don't have an answer on the generator problem.

Good luck, happy trails, and God bless!
MSHappyCampers is online now   Reply With Quote
Old 02-13-2019, 07:08 AM   #3
Senior Member
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Dec 2014
Location: Northeast Ohio
Posts: 393
I had a similar issue with mine shutting off with no load. While monitoring the frequency at any outlet I had 60 Hz with load, shut off the load and the Hz quickly climbed and the genset would shut off. Mine is too old for flash codes so I had nothing to go on outside of I thought it idled higher than it should (1800 RPM). The genset was shutting itself down for safety due the Hz.

I finally figured out that the OP had raised the hard stop on the carb to calm a surging problem. I had previously cleaned the carb which cured the surging. After resetting the hard stop it idled lower and the electronic governor could control the frequency which fixed the shutting off problem. The hard stop should be one turn after contacting a closed throttle plate, it was set at three turns.
__________________
2000 Fleetwood Southwind 32V - Ford F53 V10 6.8L 208"WB 20,500 GVWR
Randalpho is offline   Reply With Quote
Old 02-13-2019, 07:16 AM   #4
Senior Member
 
stew1's Avatar
 
Join Date: Sep 2013
Location: dickinson, tx
Posts: 322
Mine did same ran good under load died if no load replaced carburetor running good past 2 years
stew1 is offline   Reply With Quote
Old 02-13-2019, 07:19 AM   #5
Senior Member
 
Join Date: Sep 2018
Posts: 303
That's a lot of warranty work done.
Find another mechanic
__________________
Al
Al Bundy is offline   Reply With Quote
Old 02-13-2019, 10:08 AM   #6
Junior Member
 
Join Date: Feb 2019
Posts: 2
Randalpho,Stew1 - thanks for the insight, will take a look
Al Bundy - agreed!
zduffie is offline   Reply With Quote
Old 02-13-2019, 05:01 PM   #7
Senior Member
 
Join Date: Mar 2009
Posts: 1,232
Quote:
Originally Posted by Al Bundy View Post
That's a lot of warranty work done.
Find another mechanic
Agree.

Op-If you don't mind, how many hours? How much were the repairs?
__________________
In between RV's at the moment.
Pirate is offline   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 8K Diesel Model HDKAK hard start, shuts down and then runs fine TimSullivan RV Systems & Appliances 2 09-29-2016 02:13 AM
Onan 5500 Shuts Down About 10-15 Seconds After Load Unplugged By Itself ? Lincolnboy2 RV Systems & Appliances 16 09-16-2016 10:07 PM
Onan gas generator starts, runs, then shuts off MMBradley RV Systems & Appliances 8 04-04-2015 12:02 PM
Onan runs fine, but puts out no voltage Pogo Class A Motorhome Discussions 13 12-14-2012 10:55 AM
Water pump runs.... and runs....and runs tobysdad RV Systems & Appliances 8 10-19-2011 08:13 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.