Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > iRV2.com General Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-19-2021, 08:30 AM   #1
Senior Member
 
Rendon's Avatar
 
Join Date: Feb 2014
Location: Pass Christian, MS
Posts: 129
Paul Maddox HWH leveling system

Anyone out there talked to Paul Maddock lately? I have called him numerous times and have not been able to reach him and received no call back. I'm having serious issues with my hydraulic system. Had it working yesterday and now today nothing. This has happened twice now. I just don't know what to do other than try to get my slides in, Jacks are already up, and drive to Stuarts in Elkhardt, IN. And I'm in Mississippi and desperately need to get to PA to handle my brothers estate. I'm so stressed out and have already spent $2200.00. Anyone on here that can help me, I would appreciate it.
Thanks,
Peggy
__________________
RENDON
Pass Christian, MS Retired
2004 Itasca Sunrise, Full Timer
Rendon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-19-2021, 09:27 AM   #2
Senior Member
 
PJStough's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Oct 2015
Posts: 1,315
I am not sure if I can help but, perhaps with some more information others may be able to help. For starters what system do you have, 325 maybe?

When it was "working yesterday," does that mean that the jacks and slides both worked yesterday?

Also, what has already been done that cost $2200?

To me, when something works intermittently, the problem is usually a loose connection somewhere in the system.

Do you have the engine running when trying to bring the slides in?

Do you have the motorhome in park, and the park brake set?

Do you hear the motor on the pump running when trying to bring the slides in?

Have you called Stuart's to see if they can help?

Hope this helps you and others to try and solve the problem.

Best of luck.
__________________
Paul J Stough Iowa
2005 Winnebago Voyage 38J
PJStough is offline   Reply With Quote
Old 06-19-2021, 07:22 PM   #3
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 23,277
Paul was sick for a spell, not heard anything further though. I know he farms too and is quite busy through spring.



There is a procedure in your Winnebago owners manual for manual slide retraction. When new your MH came with a winch to slowly pull in the slide after opening the "Tee handle" on the solenoids for the slide room.
IF you don't have your owners manual, it may be downloaded from one of the Winnebago links in the sticky at the top of the Winnebago forum main page.


UPDATE: HWH has another manual retraction method involving a threaded rod, details here: https://www.irv2.com/forums/f54/how-...ue-506073.html
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 06-19-2021, 08:38 PM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: Jan 2007
Posts: 351
I can't help you with Paul Maddock but you might try Happy Camper Service in Picayune, MS. They are well respected and recommended by many. Also try Hickory Truck and Auto in Pearl River, La.
__________________
Scott - Pearl River, Louisiana
2018 Jayco Eagle 321RSTS 5er with 2020 F250 7.3L gas.
RottenRalph is offline   Reply With Quote
Old 06-20-2021, 09:03 AM   #5
Senior Member
 
Rendon's Avatar
 
Join Date: Feb 2014
Location: Pass Christian, MS
Posts: 129
work done so far

Thank you to all who replied. I have the 325 system. This is what was replaced.
Computer module board, switch in emergency brake, new pump motor that was defective, HWH Corp, not Stuarts, told me this is what I needed. However, there was nothing wrong with the old one thank God because the new one could not be grounded. Both pumps were able to spin when detached from the system, during installation it was found that the coupling was cracked so I ordered a new one, my guy installed it with the old motor and at first it didn't work and he said he had it tightened to hard so he loosened it and everything was working, the jacks and the slides. this was friday morning. Friday night I releveled some and I felt the jacks moving, I thought I was raising the front end of the MH only to go out saturday morning to discover the jacks were half way off the ground. I was pushing the arrow up button and rather than raising the motorhome, the jacks were storing instead. I managed to get them completely stored with no issues but when I tried to extend them, I had no power, My panel turned on but nothing would move, not jacks or slides. This happened several times before while they were working on the system. It seems that some of the wires come loose and was also shown that some of the celenoids are not looking very good or the wires attached to them. I've tried every which way to get power going, started the engine, hit the power boost button, brake is set, been working with Stuarts, and the pump motor clicks but will not activate the pump. I was told by HWH first that it was the pump motor, then they said it was the pump. They are about worthless and I won't deal with them ever again unless I have no choice. They're rude, They don't call you back but you all already know this!! lol! I do have my manual so I will have the slides pushed in manually if need be. I'm thinking maybe that coupling cracked again. But once my guy loosened it, everything worked. Idk what else to do. I will try Happy Campers, I found a guy who used to work on these systems who is supposed to call me tuesday night. What worries me is, someone will get it running again but if it stops on me while I'm trying to get to PA, I'm screwed. Won't know anyone and will prob get taken to the cleaners. After everything that has been done to try to fix this, I'm thinking I need to go to the expert, Stuarts. We already discussed me coming there. Its only 1100 miles from me!!! And I so need to be in PA like yesterday. This is so stressful. Any help or ideas will be greatly appreciated!
__________________
RENDON
Pass Christian, MS Retired
2004 Itasca Sunrise, Full Timer
Rendon is offline   Reply With Quote
Old 06-20-2021, 11:31 AM   #6
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 23,277
Paul Maddox is alive and well, he just posted last Tuesday on rvforum.net
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 06-20-2021, 11:53 AM   #7
Senior Member
 
Join Date: Aug 2014
Location: Alberta Canada
Posts: 533
Can anyone recommend a good person/company that truly knows what they are doing to trouble shoot our Power Gear 2003 levelling jacks on the WEST side of the country. Canada would be awesome (but spent several hundred here and no joy), but prepared to wait till border opens to get repaired in the USA.

We tried and tried to troubleshoot ourselves = fuses, fluid levels, changing hoses around as advised, since failure in 2018 but it's beyond our capabilities.

Thanks folks and sure hope the OP finds a good resolution soon.
SomeDay is offline   Reply With Quote
Old 06-20-2021, 03:29 PM   #8
Senior Member
 
Join Date: Sep 2016
Location: Sarasota, FL
Posts: 4,736
@Rendon - The first thing I would do is make sure you have a good ground on the pump system. Usually it gets it's ground from the mounting plate. Make sure it makes good contact and the bolts are really tight. The 2nd thing I would do is add an length of 8 or 6ga wire with ring connectors on each end and remove the end bolt of the motor (see pic) and put it through one end of the new wire and thread it back in place and tighten. Find a good place to ground this new wire to a frame point. Now if you lose the original ground, the new one will suffice. These are directions Paul gave me when he helped me with my new replacement system. No problem since.

Also check to see if you have a 40A fuse inline on the power wire coming into the pump system. If you find one (not all models have one) they are suspect to be blown. I replaced mine with a self resetting automotive CB in it's place.
Attached Thumbnails
Click image for larger version

Name:	IMG_3226.jpg
Views:	10
Size:	245.1 KB
ID:	332919  
__________________
Rick and Larrie Dee
1997 40' Newmar London Aire DP CTA 8.3 (Mechanical) 325 Spartan MM
Bringing her back to her glory.
'08 Jeep GC Overland.
RKins is online now   Reply With Quote
Old 06-23-2021, 02:18 PM   #9
Senior Member
Commercial Member
 
Join Date: Jun 2005
Location: behind the steering wheel
Posts: 2,074
hi guys, ive having some medical problems lately. kind of ongoing heart issues.
my cell is 602 549 3638. i will answer all calls as soon as possible.

please leave me a message, i dont call back on hangups.
azpete is offline   Reply With Quote
Old 06-23-2021, 02:49 PM   #10
Senior Member
 
Join Date: Aug 2011
Location: Enjoying the Western States!
Posts: 14,353
Don't use the slides until you can get this resolved.
__________________
Full-timed for 16 Years . . .
Traveled 8 yr in a 2004 Newmar Dutch Star 40' Diesel
& 8 yr in a 33' Travel Supreme 5th wheel
twogypsies is offline   Reply With Quote
Old 06-23-2021, 04:49 PM   #11
Senior Member


 
Join Date: Feb 2020
Location: NY State
Posts: 1,151
Quote:
Originally Posted by azpete View Post
hi guys, ive having some medical problems lately. kind of ongoing heart issues.
my cell is 602 549 3638. i will answer all calls as soon as possible.

please leave me a message, i dont call back on hangups.
Paul, I am sorry to hear this, and wish you a speedy recovery.

Everyone else,

Paul's support is *far* above and beyond the call of duty. Everyone takes vacations, has phone problems form time to time, or gets sick once in a while. Just sayin'.
__________________
John
1976 Southwind 28', '96 Winnie 34WK,
2006 Tiffin Allegro Bus 40QDP
n2zon is offline   Reply With Quote
Old 06-24-2021, 04:13 PM   #12
Senior Member
 
Join Date: Sep 2016
Location: Sarasota, FL
Posts: 4,736
Sorry to hear that Paul - prayers sent for a speedy recovery.
__________________
Rick and Larrie Dee
1997 40' Newmar London Aire DP CTA 8.3 (Mechanical) 325 Spartan MM
Bringing her back to her glory.
'08 Jeep GC Overland.
RKins is online now   Reply With Quote
Reply

Tags
hwh, leveling, leveling system



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with HWH Jacks, Call Paul Dutchstar411 Class A Motorhome Discussions 1 10-01-2020 09:51 AM
HWH air leveling and HWH slide out controls completely dead mhanson Country Coach Owners Forum 7 12-14-2018 09:18 PM
Air Leveling System Leak on Signature with Valid Trueline Leveling System hawkeye78299 Monaco Owner's Forum 2 07-06-2015 07:40 PM
HWH leveling System "Not leveling" TheToads Winnebago Industries Owner's Forum 5 12-04-2013 03:51 PM
HWH leveling system: fluid level check Oh-one Winnebago Industries Owner's Forum 11 03-23-2009 07:39 PM


All times are GMT -6. The time now is 05:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.