Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-24-2022, 09:42 PM   #1
Junior Member
 
Join Date: Apr 2022
Posts: 1
1984 p30 Chevy Sprinter

I have a 27ft p30 sprinter (mallard now) fixed the exhaust serpentine belt and went to start and now the ignition has no power thought the ignition switch was bad but no, went through the grounds to make sure their good, they are. Went through the fuse panel (only one I know of) under dash all fuses good. Everything works from lights to windshield wipers but no power to ignition. Someone please help me I leave for a long travel in a very short time.
Rjkj0520 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-25-2022, 08:20 AM   #2
Senior Member
 
Join Date: Aug 2021
Location: Maine
Posts: 118
Check the power wire to the distributor. If it has 12 volts then you most likely have a dead ignition module. I try to carry a spare one because they are cheap but they don't really fail that often.
__________________
1986 Itasca Sunflyer 22 ft P32 chassis with 454 engine
cadillac_al is offline   Reply With Quote
Old 04-25-2022, 07:19 PM   #3
Senior Member
 
Join Date: May 2004
Location: MI
Posts: 1,298
Where did you check to determine there's no power to the ignition? Is it cranking but not firing or not even cranking?

Chevy uses the solenoid for a battery connection to supply power to the ignition, did you check that after working on the exhaust?
Argosy is offline   Reply With Quote
Old 04-30-2022, 08:01 AM   #4
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 5,584
It's been a while since messed with 80s GM but starter wires always had to be really sanded or wire brushed or cause issues changing starter.
Is it not cranking over or no spark , if not cranking and you removed or disturbed starter wires the large wire like #8 sized one might have a fusable link and or just clean all cables stacked on starter main positive stud on starter. Check ground cable to motor.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 05-17-2022, 07:18 PM   #5
Senior Member
 
BA-in-Mich's Avatar
 
Join Date: Apr 2011
Posts: 622
look at ignition switch itself. I had to replace mine because of different issues that went on with it. The back of the switch was melted. Im surprised that it didnt catch fire. Look back on the site about 10 years ago I posted some pictures of it.
__________________
1990 28' Georgie Boy, 454, 4bbl, Thorley Headers, Recurved Distributor, 8.0 mpg. RVM 76
CAMPING: WHERE YOU SPEND A SMALL FORTUNE TO LIVE LIKE A HOMELESS PERSON.
BA-in-Mich is offline   Reply With Quote
Old 05-24-2022, 12:02 PM   #6
Senior Member
 
Join Date: May 2018
Location: Minnesota
Posts: 351
It ran fine when your parked your MH to work on it or was this a pre-existing problem? I would keep it simple to start with. You either knocked something loose or you need to check your cables/connections.

Do you have 12 volt accessory power? What's the battery condition like?
__________________
1993 Winnebago Elante 34'
PThirtysomething
454 w/4L80E
MinntoMich is offline   Reply With Quote
Old 05-24-2022, 05:48 PM   #7
Senior Member
 
BA-in-Mich's Avatar
 
Join Date: Apr 2011
Posts: 622
here are some pictures of my ignition.
https://www.irv2.com/forums/f65/igni...tch-91575.html
__________________
1990 28' Georgie Boy, 454, 4bbl, Thorley Headers, Recurved Distributor, 8.0 mpg. RVM 76
CAMPING: WHERE YOU SPEND A SMALL FORTUNE TO LIVE LIKE A HOMELESS PERSON.
BA-in-Mich is offline   Reply With Quote
Reply

Tags
chevy, p30, sprinter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1984 P30 Jack points? FlyJake Vintage RV's 2 05-17-2021 11:28 AM
1984 P30 Chevy 454 Emissions and sticker? Keyair Vintage RV's 28 11-12-2017 08:43 AM
1984 Vogue II - 29' -454/P30 - rear bath justoljim2 Vintage RV's 2 01-09-2015 06:33 AM
1984 P30 Service Manuals? marka Vintage RV's 3 06-29-2007 04:13 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.