RV Trip Planning Discussions

Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-27-2020, 06:39 PM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 3
1993 Cobra Electrical Issue

Hi all, just took my first trip in our newly purchased motor home. Learned a bunch but I have one issue that's left me scratching my head.

Before we set out I started the fridge on propane using DC power. It needed some cleaning of the burner before it started but otherwise it wasn't an issue. Everything ran fine while we were at the site and connected to shore power, but now that I'm home I'm finding that none of the propane fired appliances (fridge, WH, furnance) will start on DC power only. When I hook up to shore power or use the generator everything starts okay.

I've been through all the breakers and fuses and they're okay. I'm showing over 13v at the fuse box with my multimeter when not connected to shore power. It's bugging me as it was working before we left. At this point I'm not sure where I should focus my attention. Any pointers would be appreciated.

Thanks.
Chris_R is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-27-2020, 07:50 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 24,130
There may be a battery disconnect switch near the door that got switched off.

The stuff works from the converter/charger but with that switch off, not on battery.

I just found that mine has been off for weeks, when I pulled the shore cord out and the lights went out.
twinboat is online now   Reply With Quote
Old 09-28-2020, 07:54 AM   #3
Junior Member
 
Join Date: Sep 2020
Posts: 3
Quote:
Originally Posted by twinboat View Post
There may be a battery disconnect switch near the door that got switched off.

The stuff works from the converter/charger but with that switch off, not on battery.

I just found that mine has been off for weeks, when I pulled the shore cord out and the lights went out.
I was thinking it might be something like that. I'm still getting the lights that run on 12v and the water pump is still working, do you think a 12v shut off would allow those circuits to be independent?
Chris_R is offline   Reply With Quote
Old 09-28-2020, 07:56 AM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 24,130
They will work with shore power on.
twinboat is online now   Reply With Quote
Reply

Tags
electric, electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 Winnebago Vectra 1993 F53 RickandNeda Ford Motorhome Chassis Forum 0 10-22-2018 09:57 PM
Cobra Malibu :: 1989 Cobra Malbu ldr1960 iRV2 Owners Registry 0 04-05-2017 12:59 PM
1990 Sierra Cobra travel trailer electrical system Mike4681 RV Systems & Appliances 0 09-18-2016 04:41 PM
1993 HR Navigator Electrical Issue bem61 Monaco Owner's Forum 11 10-05-2015 07:38 PM
1993 Cobra Cordoba thread...?? ChrisNiemann Class A Motorhome Discussions 3 07-13-2010 05:55 AM


All times are GMT -6. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.