Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-22-2022, 11:12 AM   #1
Junior Member
 
Join Date: Jan 2013
Posts: 3
04 HR Endeavor “Stop Engine” dash warning

Hi all, I got the dash warning “Stop Engine” and did just that. Did some web researching and learned this has happened to lots of folks. It’s a Roadmaster chassis with a Cummins ISC 8.3L. The fault was confirmed associated with the low coolant reservoir level & when active the motor goes into derated horsepower mode (“limp mode”). Replaced the reservoir sensor p/n Q21-1026S & had the code cleared by Cummins but still have the reoccurring “stop engine” warning (it may not be on at initial start up, but has come on after running the motor for a while, then gone off again). Tested the 2-pin sensor connector and good ground on one and 4.5volts on the other... I can’t find where the operating voltage should be, does anybody know? The reservoir is always at the ‘full’ line with healthy coolant & the that cap holds pressure. Chasing the wires end-to-end now. Has anybody dealt with this before?
Larry 04 HR is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-22-2022, 12:10 PM   #2
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,653
Did Cummins provide you with the fault code. Do you have a way to check for fault codes?


Do you have a Cummins Quicksere account, if not I'd create one and register your engine. https://quickserve.cummins.com/qs3/p...ice/index.html
It takes some effort to navigate the site but under the Service tab at the top there is another tab for manuals, and then a list of links, one of which is a wiring diagram. It will show you what sensors are reporting to the ECM and what are Monaco responsibility.

On my coach it does show a Coolant Level sensor but this is mounted in/on the engine.



The part you show is what is mounted in the surge tank. From my understanding (at least on my 2002 coach) it basically uses the coolant as a way to close the circuit to ground, as long as there is coolant in the tank it senses ground. This signal goes to a Low Coolant Module made by Kysor. If it senses no coolant the alarm/light will go on. Here's a link that explains it https://www.wanderlodgeownersgroup.c...STALLATION.pdf


Are you actually seeing voltage at the sensor??
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 02-22-2022, 01:13 PM   #3
Junior Member
 
Join Date: Jan 2013
Posts: 3
Thanks Jim!

I took the coach into the Cummins service center in Everett WA and they scanned it for codes and the only one that came up (was inactive at the time) was for the coolant reservoir low level sensor. But I didn’t write down the code number.

I’ll look into registering my engine with Cummins, thanks. I have a schematic provided by Holiday Rambler of the dash wiring and sensor... but I’m not sure how it would indicate if it’s reporting to the engine ECM or just the Monaco systems.

And thanks for the sensor functionality info... I’m drilling into it now. Yes, I measured ~4.5 volts at one of the connector pins and ground on the other. I was wondering what voltage that sensor is supposed to see. By the way, I dismantled the sensor that I removed and discovered it has a small resistor embedded in it.
Larry 04 HR is offline   Reply With Quote
Old 02-22-2022, 06:37 PM   #4
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,653
You may have a different system, not sure when they may have changed.



On mine I only had one wire to the coolant sensor. On my original surge tank the sensor was inserted from the top.

The new tanks that were being sold in ~2014 when I installed my new one only had the threaded ports on the side and they were selling a Ford sensor that looks similar to the one you mentioned. I only needed one wire so I just attached 2 wires to the sensor and combined to one, and just connected it to the original wire.



Spend some time on the Quickserve site, it's taken me quite a bit of time to learn to navigate it. But it's been well worth the effort.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Reply

Tags
dash, endeavor, engine, warning



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Damon Astoria coolant low,stop engine,check engine,warning on. prento MH-General Discussions & Problems 2 06-22-2021 08:13 AM
Dash Warning Bell-won't stop liralen Monaco Owner's Forum 29 05-14-2021 07:20 AM
Intemittent ABS Dash Warning Light on 2003 HR Endeavor OT100 Monaco Owner's Forum 4 02-10-2019 06:59 PM
Check engine and Stop engine warning on start up Bounderoo MH-General Discussions & Problems 14 04-22-2009 11:25 AM
Turbo Boost / Stop engine check engine warning... jtharley Winnebago Industries Owner's Forum 1 09-15-2006 11:20 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.