RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-29-2020, 12:03 PM   #1
Junior Member
 
Spartan Chassis
Join Date: Sep 2017
Location: kittanng pa
Posts: 5
Alternator

I have a 2002 executive. amp gauge shows discharge horn honks changed the alternator still have the same problem
1schafer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-29-2020, 12:24 PM   #2
Community Moderator
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 6,776
Can you expound on your problem a bit? Are you saying the gauge shows discharge when the horn honks or just the horn honks for no reason? Are you showing 13.6+ volts with the new alternator?
__________________
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 10-29-2020, 12:34 PM   #3
Junior Member
 
Spartan Chassis
Join Date: Sep 2017
Location: kittanng pa
Posts: 5
New alternator is putting out 15 V showing 10 V on amp meter when I rev the motor the horn honks as it did with the old alternator
1schafer is offline   Reply With Quote
Old 10-29-2020, 12:45 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 24,663
If you have a battery isolator, it may be bad. That can give you strange voltage readings.

The horn ? Or an alarm inside the cab.


Isolator looks like this.Click image for larger version

Name:	Capture%2B_2020-10-29-13-44-20.jpeg
Views:	4
Size:	45.5 KB
ID:	306372
twinboat is online now   Reply With Quote
Old 10-29-2020, 01:26 PM   #5
Junior Member
 
Spartan Chassis
Join Date: Sep 2017
Location: kittanng pa
Posts: 5
Airhorns they go off at short blast
1schafer is offline   Reply With Quote
Old 10-29-2020, 10:55 PM   #6
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 1,978
If you are loosing the one chassis diode on the isolator and not some internal connection issue . You should be able to swap battery cables or flip it over if the cables wont reach. To at least test the alt. to chassis diode on isolator.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is online now   Reply With Quote
Reply

Tags
alternator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternator belt and alternator replacement jimloeh Monaco Owner's Forum 7 08-15-2016 05:10 PM
Alternator Light stays on but alternator charges augiedeg Spartan Motorhome Chassis Forum 1 10-20-2010 07:05 AM
Alternator Won't Charge Coach Batteries Captain Morgan Fleetwood Owner's Forum 2 12-16-2008 02:13 PM
Alternator issue wont go away... acampingwewillgo MH-General Discussions & Problems 6 12-19-2007 05:16 AM
Alternator overcharging Rben MH-General Discussions & Problems 2 07-27-2005 06:10 PM


All times are GMT -6. The time now is 05:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.