RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-01-2017, 09:41 AM   #1
Senior Member
 
Arby49's Avatar
 
Join Date: Jul 2016
Posts: 582
Another Genset Problem

Got ready 2 leave this morning and the on an 10k wouldn't start. Pulled the generator out and tried to start it, but only got a ticking sound. Was running fine when we shut it down yesterday. Any help is appreciated.

Russ and Lois
__________________
Russ & Lois Bell
2008 Monaco Dynasty Yorkshire IV
2013 Ford Flex
Arby49 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-01-2017, 09:56 AM   #2
Member
 
Join Date: Apr 2017
Posts: 78
Dead battery? try jump starting it with a jump box... see if that helps
bcarver78 is offline   Reply With Quote
Old 07-01-2017, 10:15 AM   #3
Senior Member
 
Arby49's Avatar
 
Join Date: Jul 2016
Posts: 582
Will try that when we stop this afternoon.
__________________
Russ & Lois Bell
2008 Monaco Dynasty Yorkshire IV
2013 Ford Flex
Arby49 is offline   Reply With Quote
Old 07-01-2017, 10:35 AM   #4
Senior Member
 
OLYLEN's Avatar
 
Monaco Owners Club
Join Date: Jan 2008
Location: Olympia, Wa
Posts: 2,771
Are you holding the start long enough to get threw the prime and glow plug heat for the start. Also try the emergency start and give it a couple minutes. Then while still holding the emergency start try the Gen start. If this all fails check battery charge and if still no joy start cleaning battery terminals and grounding points plus Gen power points 12 volt.

LEN
__________________
2004 Clss C 31' Winnebgo
OLYLEN is offline   Reply With Quote
Old 07-02-2017, 09:59 PM   #5
Senior Member
 
Arby49's Avatar
 
Join Date: Jul 2016
Posts: 582
Sorry for the delay in responding. The generator fired up after being on the road for a couple of hours. Will check batteries in the morning.
__________________
Russ & Lois Bell
2008 Monaco Dynasty Yorkshire IV
2013 Ford Flex
Arby49 is offline   Reply With Quote
Old 07-04-2017, 02:13 PM   #6
Senior Member
 
cimplexsound's Avatar
 
Join Date: Aug 2013
Posts: 893
Another Genset Problem

My Ford Fleetwood Flair has the 4k genset. Three things I always check before I ever fire the genny up. Spark plugs get oil or gas on them preventing spark. With the ONAN Genset it's a really good to take the spark plug out and clean and re gap it often. My genset has two spark plugs, so check to see if you have an additional plug. Yes, yes. Check your house battery. The starter motor on these gensets run off your 12 volt house battery. Last check to make sure your getting gas to the choke. Make sure your genset to gas tank hose on the RV is not cracked and leaking. Also check the motor oil level on the genset. My experience though is the spark plugs get fowled frequently on generators and have to be cleaned and properly re gapped often. I have a portable 900 watt generator in addition to my onboard genset. The spark plug is a frequent troublemaker!!! 😆
cimplexsound is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another Onan genset problem retired cop RV Systems & Appliances 15 09-20-2015 10:41 PM
One thing leads to another, and another, and another..... MSHappyCampers iRV2.com General Discussion 16 08-21-2013 11:11 AM
Another City another problem hpykmpr47 Monaco Owner's Forum 2 07-04-2013 12:00 PM
Another genset question Jchet MH-General Discussions & Problems 8 10-04-2012 07:45 PM
Another trip another problem jk_and_dog Winnebago Industries Owner's Forum 2 08-30-2010 10:58 PM


All times are GMT -6. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.