Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-08-2017, 06:20 PM   #1
Senior Member
 
Join Date: Feb 2012
Posts: 193
Bad leveler motor

Jack motor is not working and after talking to a Thor and a Lippert tech they both say it is the motor. When the Lippert tech gave me the news he transferred me to parts but I got tired of waiting for someone to answer, decided to call back Monday. Has anyone else had the motor go bad and do you have to get a new 12 volt motor or replace the whole pump? This is a 2015 Thor ACE MH. Thanks, Jim.
__________________
2015 A. C. E. 30.1
2004 F-150 Heritage
2004 Harley-Davidson Softtail Springer FXSTS
04fxsts is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-09-2017, 12:29 AM   #2
Senior Member
 
Brecklundin's Avatar
 
Ford Super Duty Owner
Rexhall Owners Group
Join Date: Dec 2016
Posts: 532
What is happening with your leveling system? Where in the process is the system failing?

I'm working through our HWH 610 system. Getting a non-starter "Low battery" indicator when I try to engage the system. So am checking and cleaning all the grounds...has blossomed into checking & cleaning every ground I can find...like we need more to do on our rigs! 😋

But I'd say grab your multimeter and have fun...or grab the neighborhood electrician?
__________________
'97 Rexhall Rexair w/tag, 460v8, air bags on tag and rear axle. Generac NP-66G generator with knock on wood ~4200hrs, 50amp.,~3mpg city, 7-8 mpg highway.
Brecklundin is offline   Reply With Quote
Old 10-09-2017, 08:52 AM   #3
Member
 
desertvette's Avatar
 
Monaco Owners Club
Join Date: Oct 2014
Posts: 52
I have the LCI jacks and my motor went out. If I remember right, the motor was very expensive. I pulled the motor out and took it apart. Found the motor had overheated and the brush holder was melted. Went to a local starter/alternator repair shop and got the new brush holder and brushes for around $30. BTW, my motor went bad because the hydraulic valve the controls the direction (up/down) jammed and the pump was dead-heading. I heard the motor slowing down but was unable to turn it off before it stopped. Good Luck!
__________________
Tom
2011 Monaco Knight 36PFT
2013 Jeep Wrangler Toad
desertvette is offline   Reply With Quote
Old 10-09-2017, 06:36 PM   #4
Senior Member
 
Join Date: Feb 2012
Posts: 193
Turned out OK. Decided to troubleshoot one more time before tearing anything apart and the motor started running when I jumped across the solenoid terminals. Still needed to reset the panel and called Thor tech again, this tech gave me a different sequence to reset and all is good. Jim.
__________________
2015 A. C. E. 30.1
2004 F-150 Heritage
2004 Harley-Davidson Softtail Springer FXSTS
04fxsts is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad leveler motor DougTex Entegra Owner's Forum 4 04-17-2015 01:33 PM
Bad, bad, bad - bad vibrations.... Doc Vegas Ford Motorhome Chassis Forum 21 11-30-2014 05:56 PM
Bad leak in leveler jack hose gdwooden Forest River Owners Forum 1 04-30-2014 11:24 PM
PowerGear Leveler Motor Screams Seems To overload and stall any ideas thanks Bob. Bob Mitchell Class A Motorhome Discussions 1 08-13-2012 11:23 PM
Changing the Power Grear hydraulic Leveler Motor John Stott Class A Motorhome Discussions 4 01-15-2012 06:38 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.