Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2021, 11:10 PM   #1
Junior Member
 
Join Date: Oct 2021
Posts: 3
Question Engine dies when releasing ignition key

Greetings all. RV in question is a 2001 Winnebago Adventurer. RV starts right up when I turn the key to the start position, but dies as soon as I release the key to the run position. I thought it was surely the ignition switch. Was simple enough to replace the ignition switch, but it didn't resolve anything.
Any ideas what the real problem might be?
workdogruss is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-14-2021, 12:10 AM   #2
Member
 
Join Date: Feb 2021
Location: South Jordan, UT
Posts: 98
Seems like the ecu is cutting the fuel pump and/or ignition. Have you inspected the wiring harness between ignition cylinder and the ecu? Is there maybe an anti-theft mechanism interfering? Lastly, Is it the original ignition key? If you're using a duplicate and the original is supposed to be a chipped or "smart" key, the ignition may be cutting out as a form of theft prevention....this happened to me once a long time ago, took three days to figure out.
IND2SLC is offline   Reply With Quote
Old 10-14-2021, 01:31 AM   #3
Senior Member
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Aug 2015
Location: Memphis, TN
Posts: 2,677
I AGREE on possibility of ECU, but more probable is FUEL PUMP RELAY or IGN related RELAY, in the relay/fuse box, probably under hood? Often several (plug-in) RELAYS are alike, so you can swap around and see if problem moves/ verify bad relay? (Generally), $10-$15 part until a few months ago, but unsure which brand/ chassis/ engine/ floorplan, so guessing a lot on exact details. These very small contacts relays often fail about every 10-years, should always be replaced when a DEVICE is replaced/ suspected; e.g. lighting acting up, replace lighting relays, fuel pump intermittent or replaced- replace FP relay too, if you get my drift? Roadside, look to swap a relay to get you down the road, etc. Hope this helps p.s. Forgot... INSPECT ALL WIRING FOR RODENT/ CHEW DAMAGE, Mice/ squirrels nest/ nut shells under hood a big hint to wire damage probable, too./
__________________
(TerryH.) 2000-GS Conquest Limited 6266 Class-C 99-E450SD V10
THenne1713 is offline   Reply With Quote
Old 10-14-2021, 06:28 AM   #4
Community Moderator
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 11,771
If you could specify which chassis you have it will make suggestions for a solution a lot easier.
__________________
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 10-14-2021, 09:13 PM   #5
Junior Member
 
Join Date: Oct 2021
Posts: 3
Thank you all for the swift responses. I appreciate it very much. I'll have a look at the relays and shuffle one in to the fuel pump slot to see if the problem moves. The model MH I have is the Winnebago WPG32V with the Ford chassis and V-10. I've not had a careful look at the wiring. Other than dust, it all looks factory proper and unmolested. As far as varmits, there are so many feral cats in my immediate area, no varmit would stand a chance. I'm having a friend plug in to the OBD and see what we get if swapping in a relay yields no positive results. Regarding the ignition key, my key is a plain old school metal job. Same one I've always used for years. I supposed stranger things have happened and the MH might want the original if it came with a smart key, but I've no knowledge of it coming with one when new. I'll keep you all posted with my findings. Again, thank you all so much.
workdogruss is offline   Reply With Quote
Old 10-17-2021, 09:44 PM   #6
Junior Member
 
Join Date: Oct 2021
Posts: 3
Well, there you have it! I shuffled some relays around and the ignition works great. I'm going to run down and pick up a replacement relay and a spare or two tomorrow. Thank you all for sharing your thoughts and pointing me in the right direction. Very much appreciated.
workdogruss is offline   Reply With Quote
Old 10-18-2021, 12:43 AM   #7
Senior Member
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Aug 2015
Location: Memphis, TN
Posts: 2,677
Thanks for the feedback on resolution, so glad I could help; recently looked at our main driver (retired, and no longer daily, and w/ Covid, all is worse), but... only put 3,000-miles in past 15-months... I was amazed.
__________________
(TerryH.) 2000-GS Conquest Limited 6266 Class-C 99-E450SD V10
THenne1713 is offline   Reply With Quote
Reply

Tags
engine, ignition



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine will not shut off with ignition key removed gostberg Country Coach Owners Forum 6 05-30-2018 08:48 AM
Releasing the Parking Brake prior to Towing a UFO Chassis DriVer Workhorse and Chevrolet Chassis Motorhome Forum 10 02-15-2016 07:45 AM
Ignition Key and Key Fob HzrdUs Entegra Owner's Forum 7 01-28-2016 11:56 PM
Motorhome Air Parking Brake Not Releasing rsalhus Spartan Motorhome Chassis Forum 7 05-11-2009 02:59 PM
starter battery dies..and dies artro Newmar Owner's Forum 4 08-10-2007 11:37 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.