Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-24-2021, 04:01 PM   #1
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Guardian 75D Troubleshooting

I was working in my motorhome today ( 87 degrees outside). I was running both A/C's. suddenly lost power but it came back pretty quick. Ran for about 20 minutes and power went off again. The generator was running, just no voltage. I shut down the generator, checked coolant and oil. All good. Restarted generator, had no power. After about 5 minutes, power came back on.



It loses A/C power without affecting the engine.



Could not find a troubleshooting tree with that type of problem.



Any ideas?
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-26-2021, 07:50 AM   #2
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 600
Is your unit a Quietpact 75D Generac?
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 06-26-2021, 06:09 PM   #3
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Yes it is.
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 06-27-2021, 06:08 AM   #4
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 600
Maybe this link will help.
http://www.generator-parts.com/manua...-rv/0F4996.pdf
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 06-27-2021, 07:36 AM   #5
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Thanks for the link. I did look n at that manual. I am going to get a watt meter to do complete checks on the generator.
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 07-16-2021, 04:22 PM   #6
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Might have figured it out. Yesterday, we were traveling from Dallas and started the generator. It worked fine for a few miles then quit.
When I stopped, I tried to start it and it would turn over, but would not start. Hitting the preheat switch sounded like a relay clicking on and off. I thought it was 12v dc power or a fuel pump.

Easiest thing was to check the battery cable m. Sure enough, it was corroded. Changed the connector and problem solved. At least so far it has worked without issue.
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 07-17-2021, 08:48 AM   #7
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 600
That’s good to hear.
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 07-24-2021, 11:33 AM   #8
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Well, I thought it worked. Now it won't start at all. There is a loud clicking noise from the fuel pump. That makes me assume it is a bad pump.

Any ideas of an aftermarket pump since the oem isv300 dollars.
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 07-25-2021, 08:31 AM   #9
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 600
Any possibility that the pump could be rebuilt?
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 07-25-2021, 09:10 AM   #10
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
I am not sure but I don't think so. I am going to get some fuel line and run it from the pump inlet to a container with diesel in it to make sure it isn't a deteriorated fuel line. It is a 2004 dry root is a possibility.
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 07-27-2021, 06:14 PM   #11
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Well, a new dilemma. I was just under half a tank of fuel when I had fuel problems with the generator. As soon as I filled up, I hit the preheat switch and after about 4 seconds, the clicking stopped and the generator fired up and never quit.

Weak fuel pump?
Clogged vent line for the fuel tank?
Manufacturer put the pickup tube too high on the tank?

Any suggestions?
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 07-28-2021, 05:53 AM   #12
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 600
Very possible the pickup is too high in the tank.
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 07-28-2021, 05:56 AM   #13
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Thank you. I would assume there is nothing that can be done about that short of removing the tank.
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Old 08-30-2021, 07:25 AM   #14
Senior Member
 
Join Date: Nov 2020
Location: South Dakota
Posts: 203
Quote:
Originally Posted by Randy125 View Post
Very possible the pickup is too high in the tank.
Does anyone know if the generator pickup line can be adjusted?
__________________
2004 Rexhall Roseair. 3955ET 370
bduemig is offline   Reply With Quote
Reply

Tags
troubleshooting



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Guardian 75D coolant bduemig RV Systems & Appliances 2 06-27-2021 07:40 AM
Guardian 75D (GENERAC) Diagnostic & Repair manual Honeymoo 2 RV Systems & Appliances 1 01-13-2018 03:33 PM
Guardian RV Generator Quietpact 75D M/N 4270 Hubert Green Class A Motorhome Discussions 3 11-12-2016 08:37 PM
Fuel Filter Change Diesel Generac 75D sgtjoe MH-General Discussions & Problems 8 10-04-2011 11:23 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.