Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-12-2019, 08:41 PM   #1
Senior Member
 
Join Date: May 2002
Location: Champion, PA.
Posts: 384
HWH "Level" light will not come on.

I recently had to replace the solenoid on one of my rear hydraulic jacks. After I replaced the solenoid, I tested the system and leveled the coach with no problems. Retracted the jacks and took a 600 mile trip. Upon arrival at our stopping point, I hit the level button on the HWH leveling system, which normally releases air and then allows me to manually level the coach. Nothing. The level light will not come on. I tried cycling the ignition key and some other things, but cannot get the level button to work. Any ideas?
__________________
2019 Forest River Berkshire XL40D
Stump Jumper is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-12-2019, 09:12 PM   #2
Senior Member


 
Join Date: Jul 2017
Location: Box Elder, SD
Posts: 925
Do you have a "HWH Reset" switch on your dash somewhere? I have an HWH all-air leveling system with HWH hydraulic slides and I have to sometimes use the reset switch to get it working like it supposed to.
__________________
2009 Country Coach Veranda 400, ISM 500, Aqua Hot 525D
2019 Lincoln Nautilus 2.7L Toad
2020 Lectric XP E-bike (Hybrid)
BonS is offline   Reply With Quote
Old 10-12-2019, 10:56 PM   #3
Senior Member
 
FIRE UP's Avatar


 
Join Date: Dec 2009
Location: Out there, somewhere
Posts: 9,438
Quote:
Originally Posted by Stump Jumper View Post
I recently had to replace the solenoid on one of my rear hydraulic jacks. After I replaced the solenoid, I tested the system and leveled the coach with no problems. Retracted the jacks and took a 600 mile trip. Upon arrival at our stopping point, I hit the level button on the HWH leveling system, which normally releases air and then allows me to manually level the coach. Nothing. The level light will not come on. I tried cycling the ignition key and some other things, but cannot get the level button to work. Any ideas?
May I ask, WHICH HWH system you have? We have an '04 (same year as yours) Itasca Horizon 36GD with the CAT C-7 330HP and it has the HWH 625 Computer Controlled Automatic Leveling System. And, in that one, there are no "level" lights. There however, four red LED lights on that HWH control panel, one for each jack and, also, there are four yellow LED lights, that are used for indicating which end and/or side that is UNLEVEL.

The four red lights remain OUT 'till the system starts leveling the coach. Then, as each jack is extended, the light representing each jack, will illuminate. Once the one, or two yellow lights are out, the system is satisfied that the coach is level and shuts down.

Now, I don't know if yours works that way or not since I don't know which model HWH system you have.
Scott
__________________
2004 ITASCA HORIZON 36GD, 2011 GMC Sierra 1500 4x4 Toad '18 Honda Africa Twin Adventure Sports DCT
Retired-29.5 yrs, SDFD, Ham - KI6OND
Me, Karla and the Heidi character, (mini Schnauzer)!
FIRE UP is offline   Reply With Quote
Old 10-13-2019, 07:04 AM   #4
Senior Member
 
veraken's Avatar


 
Monaco Owners Club
Vintage RV Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2012
Location: Lexington, SC
Posts: 2,575
Contact Paul at AZPETE on the Irv2 forum. He works for HWH and can answer your questions. His email is pfmaddox@att.net and his phone number is 602-549-3638. He is a Commercial Member and has posted that his phone is always on, and if not answered, leave a message.

He has helped others on this forum and I am sure he can help you.
__________________
Vera & Ken
1998 Holiday Rambler Imperial, RR8S Chassis
Cummins 6C8.3 mechanical engine, 325HP, 3060 Allison
Towing 2014 Ford Explorer
veraken is offline   Reply With Quote
Old 10-13-2019, 06:52 PM   #5
Senior Member
 
Join Date: May 2002
Location: Champion, PA.
Posts: 384
This is the same control panel that is on my unit. The "Store" light will light up but the "Level" light will not.
Attached Images
 
__________________
2019 Forest River Berkshire XL40D
Stump Jumper is offline   Reply With Quote
Old 10-14-2019, 12:59 PM   #6
Senior Member
 
FIRE UP's Avatar


 
Join Date: Dec 2009
Location: Out there, somewhere
Posts: 9,438
Quote:
Originally Posted by Stump Jumper View Post
This is the same control panel that is on my unit. The "Store" light will light up but the "Level" light will not.
So you STILL don't know which HWH system you have?
Scott
__________________
2004 ITASCA HORIZON 36GD, 2011 GMC Sierra 1500 4x4 Toad '18 Honda Africa Twin Adventure Sports DCT
Retired-29.5 yrs, SDFD, Ham - KI6OND
Me, Karla and the Heidi character, (mini Schnauzer)!
FIRE UP is offline   Reply With Quote
Old 10-14-2019, 01:59 PM   #7
Senior Member
 
Join Date: May 2002
Location: Champion, PA.
Posts: 384
Scott,

No I do not. I am self employed and work 60+ hours during the week as well as volunteering on the weekends. I have not had the chance to get the manuals out of my motorhome as it is not stored near where I live. Just thought I might get some friendly help on here from someone who had a similar problem... Sorry for wasting your time
__________________
2019 Forest River Berkshire XL40D
Stump Jumper is offline   Reply With Quote
Old 10-14-2019, 06:13 PM   #8
Senior Member
 
Join Date: Sep 2016
Location: Sarasota, FL
Posts: 5,154
You're not wasting our time.
Here is a link to HWH manuals - https://www.hwhcorp.com/web1010_techsupport.html
I would utilize the info in reply #4 - he helped me, even as I worked on the system. Paul's a good guy.
__________________
Rick and Larrie Dee
1997 40' Newmar London Aire DP CTA 8.3 (Mechanical) 325 Spartan MM
Bringing her back to her glory.
'08 Jeep GC Overland.
RKins is offline   Reply With Quote
Old 11-04-2019, 12:06 PM   #9
Senior Member
 
Forest River Owners Club
iRV2 No Limits Club
Join Date: May 2009
Location: Where I lay my head.
Posts: 1,491
Blog Entries: 5
Not sure this is helpful or not. Some years back on my Winnebago tour with the auto-leveling system, they became offset and would not level correctly.

Long story short, Go find a parking lot that you feel is flat and level. I'm thinking one of the three buttons on the left may be your reset button. So should make it AUTO RESET. I have a Freight Liner HWH set up in my RV and no manuals were helpful. Once I pushed in the correct button for about 5 or 10-sec then the system lets out all air lowering the jacks and then retracts them fully back up. So once it starts do not stop it from doing its reset. Then just do what you always do lower them.

Sure hope this will work for you.
Dogman635UT is offline   Reply With Quote
Old 11-07-2019, 08:43 AM   #10
Senior Member
Commercial Member
 
Join Date: Jun 2005
Location: behind the steering wheel
Posts: 2,250
he has a 325 leveling system. if the level light will not come on, the park brake signal is not getting to the control box. its either not set, or has a bad connection.
the dump will will always work. its the only function that works without the park brake signal. if you need help, please contact me. text or call me at 1 602 549 3638
my email is pfmaddox@att.net
paul maddox
i work full time for hwh corp. i do not sell parts or solicit service work on this forum.
azpete is offline   Reply With Quote
Old 01-14-2020, 03:30 PM   #11
Senior Member
 
Join Date: May 2002
Location: Champion, PA.
Posts: 384
Spoke to azpete on the phone. What a great guy! Turns out that there was a loose fuse in the control panel located in the rear compartment where the hydraulics are mounted. Thanks again to all those with positive comments. I appreciate your help and this site.
__________________
2019 Forest River Berkshire XL40D
Stump Jumper is offline   Reply With Quote
Old 01-14-2020, 05:08 PM   #12
Senior Member
 
Join Date: Sep 2016
Location: Sarasota, FL
Posts: 5,154
Glad you got her fixed and thanks for closing the case.
__________________
Rick and Larrie Dee
1997 40' Newmar London Aire DP CTA 8.3 (Mechanical) 325 Spartan MM
Bringing her back to her glory.
'08 Jeep GC Overland.
RKins is offline   Reply With Quote
Old 01-14-2020, 05:43 PM   #13
Senior Member
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Mar 2019
Posts: 289
Glad you got it fixed I was going to suggest check fuses.
__________________
Waldo
2005 Thor Four Winds Hurricane 33'
foundwaldo is offline   Reply With Quote
Reply

Tags
hwh, light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it normal to not have a Cruise Control "On" or "Activated" light? CountryB Monaco Owner's Forum 8 12-01-2017 11:27 PM
A "Camper" is a "Camper, and a"Trailer" is a "Trailer"! OHVtime iRV2.com General Discussion 31 10-22-2017 08:57 AM
"New Posts," "Today's Posts" and "List Subscriptions" Not Current l1v3fr33ord1 Forum 101 | Announcements | Forum Concerns 3 02-23-2016 07:28 AM
Snowbirds Come South! Do Roadrunners Go North?In the winter - the "snowbirds" come s Samarai iRV2.com General Discussion 6 09-20-2010 07:56 PM
I made my "Check Engine Light" come on! AKBrick Monaco Owner's Forum 1 09-06-2009 12:58 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.