Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-10-2021, 07:29 PM   #1
Senior Member
 
Unicorn Driver's Avatar
 
Join Date: Jan 2017
Posts: 7,079
Intermittent faulty tone ring sensor

Hi,

On a trip this past weekend my 2008 Itasca Latitude generated a faulty tone ring sensor alert while pulling in to my campsite. This morning when pulling out of the site the same happened. I had to clear the alert via the Wabco toolbox software in order to move the coach.

No alert was generated for the rest of the day.

Not sure if it was any cause but I drove the coach in a torential downpour on Thursday and it got down below freezing each of the 4 nights.

Is this something I should be worried about if the alert does not come back? Or should I have the sensor replaced?

Thanks,
__________________
2008 Itasca Latitude 37g UFO Gas pusher.
2012 Jeep Wrangler Sahara JKU.
Unicorn Driver is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-10-2021, 08:44 PM   #2
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 3,140
Are we talking ABS. Crank sensor?? ect.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 05-11-2021, 05:22 AM   #3
Senior Member
 
Unicorn Driver's Avatar
 
Join Date: Jan 2017
Posts: 7,079
Thanks its ABS.

It alerted again this morning so will have it checked out by the shop I use.
__________________
2008 Itasca Latitude 37g UFO Gas pusher.
2012 Jeep Wrangler Sahara JKU.
Unicorn Driver is online now   Reply With Quote
Old 05-11-2021, 08:05 PM   #4
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 22,761
This DOES NOT affect braking ability, it only means the brakes act like there is no ABS involved.
MIne flashed an ABS warning, my auto mechanic told me to power wash the inside of the wheels from opposite side of MH. I did, that eliminated the ABS warning, now the ABS only flashes on at startup check. He said road dirt and grime can plug the tone ring slots and fool the system to think there is a problem.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 05-13-2021, 12:29 PM   #5
Senior Member
 
Unicorn Driver's Avatar
 
Join Date: Jan 2017
Posts: 7,079
Quote:
Originally Posted by Ray,IN View Post
This DOES NOT affect braking ability, it only means the brakes act like there is no ABS involved.
MIne flashed an ABS warning, my auto mechanic told me to power wash the inside of the wheels from opposite side of MH. I did, that eliminated the ABS warning, now the ABS only flashes on at startup check. He said road dirt and grime can plug the tone ring slots and fool the system to think there is a problem.
Hi Ray,

I had the coach in the shop I use yesterday and had all 4 sensors examined. The front 2 are fine (1 is only 2 years old) but the rear 2 are in bad shape so will replace both.

Unfortunately the wheels need to come off to replace them. This is not a bad thing as it means we can have the brakes etc. inspected.
__________________
2008 Itasca Latitude 37g UFO Gas pusher.
2012 Jeep Wrangler Sahara JKU.
Unicorn Driver is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Faulty sensor or other Hwy Junky Newmar Owner's Forum 12 09-15-2018 10:36 AM
Academy Awards rally - Fire ring / Liars ring allendp Texas Boomers 2 02-27-2015 06:52 PM
7.5 Gen Set faulty temp sensor dkreb Class A Motorhome Discussions 9 01-17-2013 11:22 PM
Faulty Wind Sensor for Awning jomidabr Winnebago Industries Owner's Forum 16 12-23-2012 09:58 AM


All times are GMT -6. The time now is 11:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.