RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-27-2020, 10:54 PM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 13
Level jacks problem

Hi all. I have the power gear Leveling system In my motor home. Today I tried to level the mh but they would not come down. Turn on system, wait for it to analyze, press auto, wait light flashes continually, no action. Shut engine off, re start, Reboot system, try manual, no response. Unplugged solenoids at the leveling motor, tapped on them. Plugged all back in and then it worked. My thoughts are one of the solenoids must control the lowering of the jacks and mabe itís hanging up, is there any way to tell which one is the lowering solenoid. The system has 3 solenoids Anyone else have this issue Tks
Fleetwood40 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-28-2020, 09:25 AM   #2
Senior Member
 
Join Date: Apr 2020
Posts: 740
https://support.lci1.com/power-gear-...eveling-system
__________________
2006 Damon Daybreak 3276 35'. 3 200 Amp Lithium batteries and 2000 watt Pure wave inverter/charger.
2013 Elantra on a Master Tow dolly.
HarryStone is offline   Reply With Quote
Old 09-29-2020, 07:45 AM   #3
Junior Member
 
Join Date: Sep 2020
Posts: 13
Thanks Harry
Fleetwood40 is offline   Reply With Quote
Old 09-29-2020, 12:11 PM   #4
Senior Member
 
Join Date: Apr 2020
Posts: 740
You are welcome!
__________________
2006 Damon Daybreak 3276 35'. 3 200 Amp Lithium batteries and 2000 watt Pure wave inverter/charger.
2013 Elantra on a Master Tow dolly.
HarryStone is offline   Reply With Quote
Old 09-29-2020, 04:47 PM   #5
Senior Member
 
Join Date: Jul 2015
Location: Watertown NY USA
Posts: 3,575
Quote:
Originally Posted by HarryStone View Post
You are welcome!
Harry, I don't know how you did it but according to the times posted in the blocks to the left you answered the question 29 minutes before it was asked.
LOL
Lynn
__________________
2002 Fleetwood Storm 30H on Workhorse P32 chassis 8.1 gas.
LETMGROW is offline   Reply With Quote
Old 09-29-2020, 05:45 PM   #6
Senior Member
 
Join Date: Apr 2020
Posts: 740
Quote:
Originally Posted by LETMGROW View Post
Harry, I don't know how you did it but according to the times posted in the blocks to the left you answered the question 29 minutes before it was asked.
LOL
Lynn
I'd say I was prophetic, but you may not have your time set correctly in your user CP.
__________________
2006 Damon Daybreak 3276 35'. 3 200 Amp Lithium batteries and 2000 watt Pure wave inverter/charger.
2013 Elantra on a Master Tow dolly.
HarryStone is offline   Reply With Quote
Old 09-30-2020, 10:47 PM   #7
Junior Member
 
luis103's Avatar
 
Join Date: Oct 2015
Posts: 17
Quote:
Originally Posted by Fleetwood40 View Post
Hi all. I have the power gear Leveling system In my motor home. Today I tried to level the mh but they would not come down. Turn on system, wait for it to analyze, press auto, wait light flashes continually, no action. Shut engine off, re start, Reboot system, try manual, no response. Unplugged solenoids at the leveling motor, tapped on them. Plugged all back in and then it worked. My thoughts are one of the solenoids must control the lowering of the jacks and mabe itís hanging up, is there any way to tell which one is the lowering solenoid. The system has 3 solenoids Anyone else have this issue Tks


I had the same problem sometimes it works sometimes it wouldnít for me it was the Solenoid I opened it up clean the contacts put it back together and it worked fine you need to test the solenoids
luis103 is offline   Reply With Quote
Old 10-01-2020, 10:24 PM   #8
Junior Member
 
Join Date: Sep 2020
Posts: 13
Thanks for the input everybody.
Fleetwood40 is offline   Reply With Quote
Reply

Tags
jacks, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Ultra Level Jacks Maurice J MH-General Discussions & Problems 2 06-11-2017 08:06 AM
Power Gear Level Jacks Problem mag150 National RV Owner's Forum 0 07-04-2011 08:42 AM
Level and slide or slide then level? smackey2x Class A Motorhome Discussions 61 12-28-2010 08:42 AM
See Level II LPG level CJ7ole RV Systems & Appliances 3 11-06-2010 06:36 PM
Refrigerator...how level is LEVEL? footdoc RV Systems & Appliances 10 02-13-2007 01:46 PM


All times are GMT -6. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.