Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Toads and Motorhome Related Towing
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-23-2021, 10:47 AM   #1
Senior Member
 
TJDave's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jun 2013
Location: Wa State
Posts: 302
First RVi3 brake problem-not really!

Just posting an FYI for fellow RVi3 brake owners.

Not full timers. First tow of the of the season on the 3rd year using the RVi3. As usual, as soon as we pull away from the house/campsite, I manually apply the brake on the tablet to test that all is well. This time...nothing. Apply hard brake on motorhome and the tablet shows no toad brake applied.
So, we find a place to pull off the road before hitting the hiway. Performed a re-boot on the tablet (an option after pushing the power button. Shut down or re-boot.) About 2-3 minutes. Bam! All is good and off we went.

I am not sure why it did that. It didn't do it last year after the tablet set on my home desk all winter. Oh well. I hope this helps somebody. Happy Trails.
__________________
2005 Holiday Rambler Admiral SE 30pdd
2020 Jeep Gladiator Rubicon - Maximus-3, Blue Ox, RVi3, Cooltech
1993 Reinell 20' 5.0l - good old boat
TJDave is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Reply

Tags
brake, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Sonic - help me decide by Friday 2/5 - NSA Ready Brute, RVi3, or Brake Buddy wanderso Toads and Motorhome Related Towing 13 04-06-2021 08:50 AM
Tire Patrol System for RVI3 Brake System Jabber Jaw Newmar Owner's Forum 10 08-15-2019 10:52 PM
RVi3. brake system and tire monitor? Hawkeye Toads and Motorhome Related Towing 19 06-04-2019 05:42 PM
RVI3 Command Tablet not Charging Correctly vettenuts Toads and Motorhome Related Towing 2 07-23-2018 05:57 PM
Really, really, really dumb question.... Nuiloa Class A Motorhome Discussions 7 05-18-2012 02:03 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.