Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class C Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-11-2021, 07:59 AM   #1
Junior Member
 
Join Date: May 2021
Posts: 5
Leveler states Low Voltage and will not retract

I am new to using campers/motorhomes so forgive me if I do not use all the right words, any help on wording would be appreciated as well.
Almost two years ago I purchased a 2020 Forest River Forester 2861 DS. Skipping a lot of other nonsense 11 of those months were taken from me getting everything right and I appreciate the work the factory did to replace the side and roof after some water damage had occurred.
My current issue is with the leveler system. Yesterday I attempted to level the motorhome in my driveway as I am trying to prepare it for a trip out west to Glacier and the Pacific Coast highway with a lot of other stops along the way. As the struts were going down (3 out of 4 are down) it stopped with a message about Low Voltage - press OK to acknowledge on my One Control display. iPhone says the same when I tried using it as well. That's my problem.

What I know/have tried. I have taken the batteries out to have them tested and my friends at AutoZone tell me they are good. The batteries were purchase from AutoZone in August 2019 when it was discovered that the original motorhome batteries were bad. I have used the motorhome 4 or 5 times since the purchase the last being Jan, Feb, and March at a campground in Florida where everything seemed to work fine and I was very please with the motorhome since the rocky start we had experienced. After having the motorhome on shore power since getting back from Florida, charging the batteries with an external battery charger all night, and running the generator at the same time the leveler system again said Low Voltage - press OK to acknowledge.

I am stating up front that this has me stumped, but again I know very little about all the systems that I will have to become an expert on some day. I am not afraid to get dirty and do some of the work which I have done multiple things already. I just do not know what to do next (besides putting the batteries back in the motorhome).

Any help/suggestions would be highly appreciated.
JimForester is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-11-2021, 05:31 PM   #2
Junior Member
 
Join Date: Jan 2021
Posts: 27
Welcome aboard. What brand levelers do you have? Have you called the leveler company to see what their solution is?
RangerZ is offline   Reply With Quote
Old 05-12-2021, 04:26 AM   #3
Junior Member
 
Join Date: May 2021
Posts: 5
I have Lippert (LCI) levelers and it is controlled by their One Control system. I phoned the LCI customer support system talked to the Service Consultant. After we confirmed it was an LCI product from the software version on the One Control panel he said he could not do much more with me and that I should contact the Manufacturer. I called Forest River and they said leave a detailed message and I would be called back in the order that calls were left. That was late yesterday morning and I have not been called back.

Again yesterday earlier in the morning I had the batteries tested. Later I did crawl under the motorhome and put a voltmeter on the leads to the controller, they showed 13 volts, but obviously that was not under load. So I am waiting for information from Forest River.

In the mean time I also contacted my Dealer, RVWholesalers. The Owner, David, had one of his technicians call me and he is going to talk to one of his contacts at Forester. He is thinking maybe Solenoid or the motor itself, but that is pure guessing. I feel I am getting a lot more help out there. I do not know much yet about all these systems but I am willing to try almost anything to be able to use the motorhome again.
JimForester is offline   Reply With Quote
Old 05-12-2021, 08:04 AM   #4
Senior Member
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Aug 2015
Location: Memphis, TN
Posts: 2,010
Most auto retract when IGN= ON, So start/ run, 15-30-minutes, then shut off and extend?
__________________
(TerryH.) 2000-GS Conquest Limited 6266 Class-C 99-E450SD V10
THenne1713 is offline   Reply With Quote
Old 05-12-2021, 04:27 PM   #5
Junior Member
 
Join Date: May 2021
Posts: 5
Thanks, but the only way to get the leveling system to function is with the ignition on and engine running.

I have tried this many times, on shore power, with generator, both shore power and generator (always with the ignition on) and using auto retract, manual mode, or Auto level I get the same error.

Putting a voltmeter there is voltage to the controller under the unit, but I cannot operate the system while laying underneath it (not would I want to try) to see how much the voltage drop is.
JimForester is offline   Reply With Quote
Old 05-15-2021, 08:48 AM   #6
Senior Member
 
Matt A's Avatar
 
Vintage RV Owners Club
Join Date: Jan 2016
Posts: 207
I have LCi Power Gear levelers on mine. Similar process as yours, engine running, parking brake set, etc. there are two 150 amp fuses about 18 from the chassis battery. One of those is running power to the leveler hydraulic pump. Id look at that fuse if yours has it and at the solenoid on the pump that activates that large power wire.
__________________
1995 Fleetwood Flair 22D
2015 Fleetwood Flair 26E
Matt A is online now   Reply With Quote
Old 05-15-2021, 03:02 PM   #7
Member
 
Join Date: Dec 2010
Posts: 57
I have a 2019 Entegra Esteem 29V with a similar problem. My jacks would not go up or down. To make a long story short I replaced the Controller which is the brain of the system, not the control panel, and everything is working like new. Pretty pricy part. I hope this helps.
Richie is offline   Reply With Quote
Reply

Tags
low voltage



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear Manual Leveler Low Voltage geraldz MH-General Discussions & Problems 5 02-04-2018 11:38 AM
POWERGEAR Leveler will not retract. SBRICHERS MH-General Discussions & Problems 3 04-29-2017 05:00 PM
Lippert jacks will not retract "low voltage" P-Dawg Class A Motorhome Discussions 16 08-29-2016 12:20 PM
AGS start voltage vs Low Voltage Cutoff pilotspike Newmar Owner's Forum 8 04-25-2016 10:06 AM
Battery Voltage Sag and Low Voltage Cutoff Pullin' Chocks RV Systems & Appliances 8 08-19-2014 10:46 PM


All times are GMT -6. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.