RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > Members List
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Mochisme's Profile Picture
Mochisme is an unknown quantity at this point

Mochisme Mochisme is offline

Senior Member

Profile Comments

Showing Profile Comments 1 to 4 of 4
  1. Nuclear
    04-30-2014 08:33 PM
    Nuclear
    It's ok! All turned out well. The inverter has a search knob...mine was basically sticking...after a few back and forth turns if the knob and it worked perfectly! I got that advice from the manufacturer, great advice, but cost him a $1,200 sale.
  2. Nuclear
    04-26-2014 09:21 AM
    Nuclear
    Sorry my post is a bit confusing, I had too many characters in it and had to delete a bunch to send it. Basically I can't find what's wrong with the 12 vdc system and don't know if I'm reading the panel correctly.
    Again...sorry for the mixed up text
    Dave
  3. Nuclear
    04-26-2014 09:18 AM
    Nuclear
    Greetings!
    I'm trying to learn the electrical system...wow complicated.
    I ended up replacing all my batteries--chassis battery was original and spent...so it's gone, replaced with Energizer 64 group--850CCA.
    The four 6v coach batteries are from 2008--they were very low on voltage, swollen, and dry with plates exposed. Now as I think about it, they never did start the generator...
    So here is my two questions I'm hoping you can address:
    1. The panel over the entry door...shows 14.5 volts, the % was 25 then dropped. Charge was bulk. This is with the new batteries installed and a charge on the system. Why 25% charged? And then dropping? I try cutting all power usage, and at one point plugged into a 120 15 amp power cord. No increase. Not even from the generator (which starts right away on the new batteries). Battery voltage is 13.5...charge voltage is 14.5.
    2. When I check the panel in the bathroom (press test) lights come on but do not give me an indication of battery.
  4. Nuclear
    04-17-2014 10:05 PM
    Nuclear
    Greetings!
    I couldn't help but notice your MH...we just purchased a 2000 la palma...pick it up next Monday! Same color as yours, our floor plan and model number matches a 2001--is that normal??
    So any advice for me? Anything I should do or not do? It has 22k miles and original tires (I'm replacing them on Tuesday).
    Thanks for letting me be nosy!

About Me

  • About Mochisme
    City
    Shoreline
    State or Province
    WA
    Country
    USA
    Location (City, State):
    Shoreline, WA
  • Signature
    Mochisme "Ted"

Statistics

Total Posts
Profile Comments
Blog
General Information
  • Last Activity: 09-24-2018 06:29 PM
  • Join Date: 06-26-2011
  • Referrals: 0

All times are GMT -6. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.