iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Allison Transmission Forum (https://www.irv2.com/forums/f125/)
-   -   Allison Locked-Out and stuck in the driveway (https://www.irv2.com/forums/f125/allison-locked-out-and-stuck-in-the-driveway-108622.html)

CalvinW3 11-20-2011 10:04 AM

Allison Locked-Out and stuck in the driveway
 
I have a motor home with a Cummins 6BT engine coupled to an Allison MD 3060 transmission. I started-up in the driveway to depart on vacation and the light on the dash said: "Do Not Shift". The digital readout on the pushbutton shift selector blinked erratically and then went blank. I was able to get it into the diagnostic mode and the codes are: D1= 45-15, D2=45-12, D3=--, D4=--, D5=--

If I am reading the code manual correctly, 45-15 means D solenoid circuit open and 45-12 means A solenoid circuit open. It seems odd that two solenoids would fail at the same time.

How can I get better diagnostics? I cannot clear the codes. Is there a way to override so I can get the coach to the service provider?

Mike Canter 11-20-2011 11:20 AM

I think you should first try getting under the MH and check all the plugs on the transmission. Make sure they are tight. It maybe best to disconnect them then reconnect them. Let us know how that comes out

Iron Man 11-21-2011 04:39 PM

To beat a dead horse, check all the grounds and make sure they are tight and have no corrison issues.

CalvinW3 11-26-2011 06:41 PM

I am checking all of the connections on the wiring harness but I need to know which wires are the grounds. I feel like I am working blind. Does anyone have a wiring diagram for an Allison 3060 or 3000, 4000 series?

ottffss 11-26-2011 06:49 PM

Quote:

Originally Posted by CalvinW3 (Post 1018209)
...Does anyone have a wiring diagram for an Allison 3060 or 3000, 4000 series?

Maybe the Allison web site is a place to start??

Allison Transmission

Try "service" --> "My Transmission Information" and enter your xmision serial number. Might get you exactly what you are looking for a little quicker...

WilliamHorn 01-23-2012 07:07 AM

I have the same problem, did you ever get it solved?

Mike Canter 01-23-2012 08:06 AM

Bill, what year is your Dynasty? It seems that over the years this problem has been posted many times. The ECU for the Allison is in the control box in the arm rest. It receives its power via a separate wire from the chassis battery. This separate wire normally has both an inline fuse and a crimp on butt connector and almost 100% of the time it is that connector that is bad. This fuse and butt connector are usually located in the chassis battery compartment.

WilliamHorn 01-24-2012 07:00 AM

I have a 1994 Dynesty. Besides the do not shift lit up and the shift console out the tach doesn't work. I had a mechanic out yesterday that roadside service sent out, he could not figure out what was wrong..

Thanks for replying
Bill

openminds 01-27-2012 01:26 PM

Check upline on your wiring as well, make sure no critters have chewed through any of your tasty wiring.

Yes, this is from prior experience. :banghead:

Donn B 03-02-2012 01:02 PM

New post to old thread, same old problem. Allison website is useless for finding the information I need. The is a 1990 Blue Bird Wanderlodge and I need to figure out what tranny I have so I can order documentation via a dealer. Currently because of where it is parked and the deflated air bags I cannot get to the tranny to look for a plate. The TCH has the following information:

Service number 1228283
S/N appears to be 4386
Date code 8124
P/N AZJT (over) 16081269 (this is scribed by hand)

Does any of that give a clue to the tranny model?

st687 03-02-2012 05:26 PM

Don, call Parliament Coach in Clearwater FL. they have all the old Bluebird paper work,with your vin# they should be able to help you.:dance:

mel s 03-12-2012 05:12 PM

Allison VCM relays/solenoids
 
I had a similar "do not shift" problem.
There are two fuses and 5 or 6 "Bosch type" automotive solenoids/relays in the Allison VCM (vehicle control module) which apparently control the shifting.
The VCM is a 6" square plastic box with a plastic cover held on with screws. (Mine is located in the cab, up under the center of the dash, on the back of the front firewall).
Remove the cover, unplug the solenoids one by one and bench test them.
I found one bad one and when I put that one new one in, along with the ones that had tested OK, the shifting function was restored!
(Don't do as I did and remove all of them at the same time, they are all identical and I don't know which one I took from which socket, however, it did work, and has for over 70,000 miles).

BTW, 90,000 miles ago I had a bad/(corroded?) wire from the batteries to the VCM, which allowed 12v to pass trough it, but did not pass sufficient amps for the shifter to function.
(After a 25 mile tow, four days, 20' feet of 14ga wire, and $2,300 out of my bank account, I was back on the road)!
Mel
'96 Safari Sahara

Donn B 03-13-2012 05:16 AM

Suppose I ought to post an update.

From all the references I could find the problem is usually rooted in either low voltage (bad batteries) or restricted current flow (bad cabling). My problem actually turned out to be a combination.

This coach does not have start batteries. It has a bank of eight 6V deepcells that serve as both starters and house batteries. Four of them were failing under load so I replaced all eight. This cleared the warning light and the audible alarm, but the tranny still wouldn't shift.

Next I disassembled all the packed-in stuff that was in the way (really big job) to check plugs and chassis grounds, pulling each off, cleaning, burnishing and reseating. When the tranny shifted on the first try I was elated, but when everything was reassembled and remounted (a truly big job) I found that I was right back where I started... no shifting with both light and alarm.

After disassembly (big job again) and repeating all previous steps I once again could shift, but the alarm would intermittently sound and the light flash, so I started tracing wires to find what I figured was something loose. What I found instead was a previous repair and three solder joints. The repairs had been done well enough except that they were only wrapped with tape. I desoldered so that I could use heat shrink tubing.

Upon reassembly (whew, getting tired of this) and testing at each stage I never experienced the problem again. So honestly I don't know if one of the solder joints was bad, a second cleaning and burnishing was more effective, or if I just accidentally repaired the problem.

Frustrating not to know, but at least it works now. Thanks for the Parliament Coach advice. I read somewhere that they managed to emerge from bankruptcy so maybe they still have those records. It would be nice to know a little more about this coach.

CalvinW3 06-26-2012 05:21 PM

Thanks for the help you all provided. I checked and cleaned all of the connections, cleaned the circuit boards, and somewhere along the way the problem was fixed. The only thing that bothers me is I don't know for sure where the bad connection was....


All times are GMT -6. The time now is 06:24 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.