iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Class A Motorhome Discussions (https://www.irv2.com/forums/f258/)
-   -   speedo really off (https://www.irv2.com/forums/f258/speedo-really-off-123360.html)

Dunner 05-14-2012 10:20 AM

If that doesn work, here are some post from another speedo problem thread.


Quote:

Originally Posted by Darrell & Mel (Post 341657)
SRT,
I changed the speed sensor ($21) the other day and took my coach out for a test drive. To my chagrin, the speedo still did not work. I finally gave in and took the dash apart and removed the instrument cluster. My wife then drove 2 and 1/2 hours to Richmond, VA to drop it off with Southern Electronics. As soon as she walked in and told them what the problem was, the technician new exactly what the problem was. Said he'd seen it lots of times, even with F350 and F450 Fords. Southern Electronics turned it around in one day ($215), my wife drove back to Richmond to pick it up, and I just got finished installing it again. I will test drive it tomorrow and hopefully it will be fixed. I will post another update after the test drive. https://www.irv2.com/forums/eve_images/2thumbsup.gif

Quote:

Originally Posted by Darrell & Mel (Post 167446)
Sorry, I never posted a follow up. We did go camping over the Memorial Day weekend, and the speedo worked great! So it did turn out to the the speedo part of the instrument cluster. If anyone needs work performed on their speedo or instrument cluster, I highly recommend Southern Electronics. You can find them on the www. They provided a quick turnaround for me at a good price. And if you are in the DC area to do some sightseeing, I highly recommend Cherry Hill RV Park. Nice, friendly staff, great location to the monuments with easy access via the Metrobus and Metrorail.

Does this help?





All times are GMT -6. The time now is 03:41 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.