iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Vintage RV's (https://www.irv2.com/forums/f65/)
-   -   Kwikee Step Wiring (https://www.irv2.com/forums/f65/kwikee-step-wiring-171833.html)

gt350ed 08-08-2013 12:38 PM

Kwikee Step Wiring
 
1 Attachment(s)
Howdy! Haven't been here in awhile. Got a new problem. I recently installed a new Kwikee Electric step that is all but an exact replacement for the old one EXCEPT it's more modern and MAYBE has a bit different way of working.

Anyway, this is probably easy, but I'll be darned if I can figure it out. The step's operation SEEMS to be working backwards. When I connect the 4-wire plug under the step, the step opens...with the door closed. When I open the door, the step retracts. NOT GOOD.

I have a toggle switch just inside the door on the left by the handrail. There is also a plunger switch below the door lower hinge. AND there is the typical switch on the dash for retracting the step, although THIS new step is supposed to have ignition override.

The step came with a pigtail to splice into existing wiring. Once spliced, it becomes a matter of simply plugging supplied male and female connectors.

I'm sure I have a wire reversed, but I'm not sure how. All the existing wiring for the step throughout the coach is untouched. And the fused "entry step switch" wire is connected to the positive side of the engine battery.

I'm attaching a diagram. Any ideas?

vtbigdog 08-08-2013 01:08 PM

Your new step should have come with a new switch. Did you install that switch? If not this is the cause of your problem.

The old switch is normally closed and the new switch is normally open. This was done for safety reasons.

gt350ed 08-08-2013 01:18 PM

Quote:

Originally Posted by vtbigdog (Post 1677150)
Your new step should have come with a new switch. Did you install that switch? If not this is the cause of your problem.

The old switch is normally closed and the new switch is normally open. This was done for safety reasons.

By George, I think you're on to something. I did NOT install it. Let me check into that. Thank you. I'll report back.

Ed


All times are GMT -6. The time now is 02:12 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.