iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Caterpillar Engine Forum (https://www.irv2.com/forums/f124/)
-   -   Engine turns over but won't stay running (https://www.irv2.com/forums/f124/engine-turns-over-but-wont-stay-running-212598.html)

elavin 07-22-2014 12:06 PM

Engine turns over but won't stay running
 
We are currently sitting in Thayne Wyoming waiting for a tow truck to tow us back to Idaho Falls. When we went to leave this morning, our motorhome would not stay running. It turns over okay, but we get a lot of black smoke and it then stalls out.

Just wondered what we are possibly looking at for repairs? Any ideas?

Skip426 07-22-2014 01:56 PM

Welcome to iRV2.
What year is your Cat ? Chassis under your motor home a Freightliner?
Does your dash go through the wait to start bulb check?
A lot of older Cat setups have a single inline 20 amp fuse, between the battery and the Engine Control Module. If that fuse is blown the engine will turn over but not start.

Mekanic 07-22-2014 02:02 PM

black smoke is odd on startup. sounds like its starving for air.

Skip426 07-22-2014 02:11 PM

Quote:

Originally Posted by Mekanic (Post 2149391)
black smoke is odd on startup. sounds like its starving for air.

Good thought, perhaps the coach has been sitting long enough for something to nest in the air intake. Worth a check .:thumb:

DieselTech39 07-22-2014 02:24 PM

Quote:

Originally Posted by Mekanic (Post 2149391)
black smoke is odd on startup. sounds like its starving for air.

Quote:

Originally Posted by Skip426 (Post 2149405)
Good thought, perhaps the coach has been sitting long enough for something to nest in the air intake. Worth a check .:thumb:

:iagree: Check to see if some furry, mutant critter crawled in for a ride along. :eek: Have you changed air filter or checked the service gauge for the air filter?

BTW I noticed you've been a member for a while but this is your first post...

:welcome:

Best of luck in finding a solution to your issue, When you get it fixed enjoy your adventures and be safe.

Mekanic 07-22-2014 03:17 PM

If something made a nest, and the engine started the whole mess is likely to be sucked up against the inlet side of the Turbo.

I would NOT keep starting it.

elavin 07-22-2014 08:44 PM

While we were waiting for the tow truck, I decided to try one more time. It started with no problem. We have an appointment with freightliner tomorrow morning here in Rock Springs, wy. Thanks for all the suggestions. Motorhome is a 2002 with a 330 Cat engine.

DieselTech39 07-22-2014 09:03 PM

Quote:

Originally Posted by elavin (Post 2149946)
While we were waiting for the tow truck, I decided to try one more time. It started with no problem. We have an appointment with freightliner tomorrow morning here in Rock Springs, wy. Thanks for all the suggestions. Motorhome is a 2002 with a 330 Cat engine.

Glad you got it started.:thumb:

Any black smoke? Misfiring?

Just a note, it would be helpful if we had a little more info in the first place. If you clicked on the "User CP" in the blue tool bar above and scrolled down to the "Edit Signature" on the left and clicked on it you could enter your coach information Make, Model, Engine Model and HP, and any other information about your RV; , and this will show up each time you post so that responders to your post would have that info available to assist you.

Best of luck at FL. Would be great if you let us know what they find.

elavin 07-23-2014 09:31 PM

New to this forum. Think I did this right.

DieselTech39 07-23-2014 09:38 PM

Quote:

Originally Posted by elavin (Post 2151460)
New to this forum. Think I did this right.

If you mean your signature info, not yet, didn't show up. When you get the info in you have to scroll to the bottom and click the save changes.

elavin 07-23-2014 09:40 PM

Thanks. I went on and changed the signature.

DieselTech39 07-23-2014 09:43 PM

Quote:

Originally Posted by elavin (Post 2151478)
Thanks. I went on and changed the signature.

:thumb::thumb: You got it!

[edit] What did you find out from Freightliner?

elavin 08-06-2014 06:23 PM

Thought I'd give an update regarding our intermittent starting issues. When we mentioned it to freightliner while getting our radiator flushed and cleaned, he said it might have been just a hiccup. Well, while waiting for our windshield to come in, again it would not start. Had a mobile mechanic come and change the fuel filter. Next day still happened again. We got it started, drove to get the windshield without turning off the engine. Made an appointment with a Cat dealer. Stayed 3 days waiting for the appointment and darn...didn't it start right up. He thought it might be 50 50 that it was a check valve. We were going to change it, but when they went under to bed, he realized he couldn't reach it without tearing the bed all the way out. That would have been 2 days and a night in a hotel. So to make a long story short, we are again on the move...praying that it starts every time.
Any other suggestions anyone???

Skip426 08-06-2014 10:45 PM

I have to log off at the moment , company arrived , I'll get back to you in the AM. I'm scratching my head.


All times are GMT -6. The time now is 04:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.