iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Fleetwood Owner's Forum (https://www.irv2.com/forums/f107/)
-   -   Bounder: Bounder Kwikee Step Fuse (https://www.irv2.com/forums/f107/bounder-kwikee-step-fuse-252650.html)

Brockx 06-29-2015 08:47 PM

Bounder Kwikee Step Fuse
 
My step lost power returning to close after opening the door with the engine running. I can't locate the fuse, checked every fuse in the panel in the bedroom. I believe it should be powered on the chassis side (my 1996 was under the hood in a master panel). I have the troubleshooting guide etc. would like to find the fuse first.

CLIFFTALL 06-30-2015 03:15 AM

1 Attachment(s)
The step switch and motor fuses are in the BCC ( battery control box ).
Mine was located in the first compartment on the passenger side.

CLIFFTALL 06-30-2015 03:16 AM

2 Attachment(s)
Attachment 98735
Attachment 98736

Brockx 06-30-2015 03:28 AM

Quote:

Originally Posted by Clifftall (Post 2627128)


Thanks Cliff, That is the same type box my 1996 had on the firwall. So far I have not seen that box on my 2008. Looks like I have a search on my agenda, the first bay on mine is a "dummy" with the leveler system behind it. The next bay has the outside entertainment hook-ups. All my bays ahead of the rear wheels move with the slides.

CLIFFTALL 06-30-2015 03:42 AM

FW should be able to point you to it.
800-322-8216

Brockx 07-04-2015 10:38 AM

Found the box!! Right where Cliff pointed me to go. I was in that cubby-hole once before and only saw the Powergear leveler controller. The panel cover to the cubby is only about one foot wide by 6 inches tall, the master control is back to the left and extremely difficult to access and check fuses. What was Fleetwood thinking!!!!

Anyway the fuses were good. I removed the strap I had holding the steps up, reinserted the Clevis pin, and reconnected the power plug. I opened the door the steps came out, closed the door and they closed about 3/4 of the way, then nothing again.

I'm suspecting the controller, I ordered the test connector from E-Bay Tuesday but the guy has not shipped it yet !@@#$$$. I could dink around with jumper wires but much easier with the jumper. Not my first Rodeo with steps, replaced gear slugs, motor, magnetic switch on my old coach, so we will "gitter dunn" eventually. Any and all thoughts welcome.

Happy 4th!!!!

Brockx 07-08-2015 08:22 AM

Update

Supposedly shipped my harness yesterday, unfortunately, I will be in WA. state for the next week.

Brockx 07-26-2015 02:17 PM

Got the steps working today.
Ended up being the motor, everytime I disconnected and reconnected power it would cycle closed about half way and stop. I ordered an automotive replacement (same part number I used on my previous MH) and the output shaft was not the same. I ended up ordering a Kwikee 1101428 from Amazon and it was correct, but also $78. This thing was really puzzling, it would always stop the same place, putting 14 volts directly to the plug would just generate sparks. Took the motor apart cleaned the commutator and brushes and it would run both directions freely. Re-installed and stopped same place, apply outside power 14 volts, nothing except sparks, both free and under load :facepalm::facepalm::facepalm:. By the way the steps would swing totally free.

Kwikee arrived today installed it without a hitch, steps work perfect, thinking old motor must have an "open" in one of the windings. The old motor had a tag on it "Tested 1/31/2014" so it was replaced last year, I bought the coach 11/2014.

I started a thread in RV Systems looking for a possible Automotive part number for a replacement (spare).

CLIFFTALL 07-26-2015 02:26 PM

Thanks for the update. Glad you got er done :)


All times are GMT -6. The time now is 08:18 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.