iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   National RV Owner's Forum (https://www.irv2.com/forums/f105/)
-   -   No power to water heater element (https://www.irv2.com/forums/f105/no-power-to-water-heater-element-255405.html)

ShapeShifter 07-22-2015 12:39 PM

Good detective work! After all your efforts, I would have to agree that it's time to order a replacement board.

Samflhomes 07-22-2015 01:37 PM

Ordered from american rv company as recommended by Mark at Atwood
$147.53 delivered
It is a new part number 93851 which uses pins instead of the two slide on connectors. Comes with an adaptor to accommodate the slide on connectors which in the end accomplished nothing except we are using most current circuit board. Hopefully with improved circuitry


Sam

Explained to Mark how I diagnosed. Told him it was a piece of cake!

YC1 07-22-2015 05:05 PM

Just one note of caution when activating a relay/solenoid. Holding a bare paperclip could give you a surprise minor zap. The zap will not hurt you but getting your hands out can often lead to cuts and scrapes. The coils act just like ignition coils do when their fields are charged up or discharged.

Shapeshifter is an amazing talent with the keyboard and incredible advice. I hope I grow up to be just like him.

Now maybe he can help me with my diesel particulate filter. Never mind, we were towed to the Cummins dealership in Albany New York a couple of hours ago. Plugged into their 50 amp outlet for the night. Should be an easy fix tomorrow. They already read the codes.

ShapeShifter 07-22-2015 06:41 PM

Sam and Myron, thanks for the kind words.

Quote:

Originally Posted by YC1 (Post 2661681)
Just one note of caution when activating a relay/solenoid.

That's true. But this is a pretty small relay and the risk, while not zero! is small. ;)

Quote:

we were towed to the Cummins dealership in Albany New York

Sorry to hear of your troubles. What're you doing this far up North? Too bad it's not a week later: next week we're heading to the RV show at Turning Stone Casino, in Verona, about 100 miles from Albany.

Samflhomes 07-22-2015 07:45 PM

I'm on a campground in Clarion Pa my home town is Elmira New York
But I have lives in Sarasota over 30 years

Next problem is to figure out why my tv antenna no longer provides a signal to TV it's one of those wingard wind up

Sam

ShapeShifter 07-22-2015 07:54 PM

Quote:

Originally Posted by Samflhomes (Post 2661900)
I'm on a campground in Clarion Pa my home town is Elmira New York

Wow, you're only about 3 hours from me. We almost could've swapped control boards.

Quote:

Next problem is to figure out why my tv antenna no longer provides a signal to TV it's one of those wingard wind up
It could be something burned out in the antenna, but it's more likely a power issue or bad connection: cut/corroded/loose, etc. how does it get power, is the power light on?

Samflhomes 07-28-2015 11:49 AM

To wrap this report up

I installed the new circuit board today
Original part 91226 replaced by kit 93851 which contains an adaptor board. Found that the adaptor was loose due to my not seating the adaptor firmly on to the pins until it snapped in place

All works great now. A low humming notice comes from the board but I expect that is normal.

Thanks again for all the help in finding access to the element, learning how to use a meter, how to diagnose 12 and 120 volt. Kudos to shape shifter for his detailed advice

ShapeShifter 07-28-2015 12:02 PM

Thanks for the kind words, and congratulations on a successful repair!


All times are GMT -6. The time now is 10:09 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.