iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Monaco Owner's Forum (https://www.irv2.com/forums/f115/)
-   -   New to me '99 Windsor 34' (https://www.irv2.com/forums/f115/new-to-me-99-windsor-34-a-294252.html)

mmorgan 06-06-2016 08:45 PM

New to me '99 Windsor 34'
 
Recently sold our '07 Fleetwood Expedition and bought the Monaco from a friend in Florida.

We really like the coach and it is in really great shape for being 17 years old. We especially like the fact that we now have approximately $60,000 less money invested in a motorhome....yes we gave up a few things but for $60k a few sacrifices can be made!!!!

Been working through a few issues...the two main ones are speedometer error and the RVA manual levelers.

The speedometer reads anywhere from 7-15 mph high....been told it probably is a grounding issue with the problematic gauges in the panel (fuel gauge also doesn't work). I have cleaned every ground I can find and even added one from ground terminal in front hood back to the panel. Any other ideas??

The jacks initially would not make any sounds when I tried the extend buttons. I changed the "leveler safety" relay in front elec bay under driver seat and the pump motor suddenly came to life.....only problem is it comes on with the ignition switch and will not go off unless I kill the power to it. It comes on in "bypass" mode as it is a loud whine and if I fiddle with the extend buttons I can get the jacks to move down an inch or two at a time all while the motor is screaming going in and out of bypass and extend modes ( it changes sounds when the jacks move)
Can't figure out why its wired direct to the ignition switch and now when I put the old relay back in and it works the same way as with the new relay. Green light comes on with the jack switch on the jack control panel but it has no effect on the motor.
I have talked to Dennis at RVA and he had no ideas (hard to diagnose over the phone)
My next idea is to find the control box and maybe wire up some jumpers and see if I can get the jack switch panel to control the motor instead of the ignition
switch. I did disconnect all the extend switches in case one of them was stuck in the extend mode but nothing changed.

Any other ideas??

Robi.1014 06-06-2016 10:01 PM

Only addressing this: " I changed the "leveler safety" relay in front elec bay under driver seat and the pump motor suddenly came to life.....only problem is it comes on with the ignition switch and will not go off unless I kill the power to it."

Wonder if the relay you installed is NC (Normally Closed) when the original Monaco relay was NO (Normally Open). I don't mean to imply one or the other is "correct".....just that what you describe might be tracked-down to something this simple. You'll need an electrical schematic to help troubleshoot this, I'm guessing.

mmorgan 06-07-2016 07:41 AM

If I understand the relay wiring correctly, it has five pins and you can hook it up either way. It is an exact match to the old one and also if you note above I put the old one back in and it is acting the same way.


Sent from my iPad using iRV2 - RV Forum

barmcd 06-07-2016 03:55 PM

My speedometer and tachometer gauge wander around a little bit too, above and below whatever is happening at the time. I've been told that if cleaning the grounds and even adding a ground to the instrument ground bar doesn't fix the problem you can add a 330 ohm resistor between the two posts on the meter and it should fix the problem. I have a GPS which gives me speed so I haven't tried the resistor fix.

I may rig up a resistor on some alligator clips to try out the speedo fix and see if it works.

I'm perplexed by your jacks. My key has to be in the ON or ACC position for the jack panel to come on. It has a separate on/off switch on the panel itself.

mmorgan 06-07-2016 09:14 PM

Haven't heard about the resistor fix.....I also use a GPS but it just bugs me that is so erratic. Let me know if it works.

I am the kind of person that "if its in the coach then it needs to work."

Yes I can probably do without jacks....carry a few boards or leveling pads but i would like the levelers to work like they are supposed to.

On the start solenoid for the pump motor there is a small wire in the center that goes "somewhere".....hard to trace when they disappear in the bundles. When I disconnect that wire it kills the power to the motor. According to the wiring diagram that wire is for "transmission interlock relay" I will try to trace that wire but it probably goes back to the "leveler safety" relay that I have been messing with.

I am also "perplexed"...LOL


All times are GMT -6. The time now is 07:47 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.