iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Monaco Owner's Forum (https://www.irv2.com/forums/f115/)
-   -   Eaton Vorad model EVT-300 smart cruise issue (https://www.irv2.com/forums/f115/eaton-vorad-model-evt-300-smart-cruise-issue-377791.html)

vito.a 02-05-2018 04:16 PM

Eaton Vorad model EVT-300 smart cruise issue
 
I originally posted in an older thread but now think it’s better to start a new thread with current information. My Eaton Vorad model EVT-300 smart cruise has stopped working. I have a constant red fail light on the left windshield pillar display. Eaton originally built the system for class 8 trucks and worked with Monaco to install it in 2004-2010 motor homes. The original Eaton engineer was Rick Youngblood. Scott Zimmer (now at Source Engineering) did much of the original engineering work with Rick.
In 2011 Eaton sold Vorad to Bendix Corp.
https://www.bendix.com/media/document...rtedbybcvs.pdf
I’ve phoned and emailed Bendix (both Barbara and the Bendix help line) multiple times with no help. As soon as you say Vorad they put you on terminal hold.

For those of you not familiar with Vorad, it’s a radar system that gives a sound warning, a red light, and slows the coach when someone is in front of you and also warns you if someone is in your blind spots (left or right). It’s a great system and can track up to 20 targets at a time. My wife loves it as I tend to follow too close. When it dies the main cruise also does not work. I posted in an older thread here:
https://www.irv2.com/forums/f115/vora...-222914-2.html

I ran the system diagnostics. You hold the left volume knob in for 8 seconds to place the system into the diagnostics mode. With the right range knob turned left of center it flashes active codes and with the distance knob turned to the right it flashes inactive codes (you have to count light flashes like OBD 1 codes). It flashes 41 telling you it’s in diagnostic mode and then the codes and then 41 again saying it’s complete.
I have no active codes and 11, 15, 33, 34, and 35 inactive codes.

I removed both radar side sensors (very easy, just 4 bolts and a wire connector) and installed them on opposite sides to see if the red left fail light would follow the sensor. It does not. I still have a constant fail on the left and nothing on the right. This information and the codes I have are pointing towards a central processor unit (CPU) issue.

I removed the (CPU). This electronics box is installed under the left side console next to the driver’s seat. I removed both the side panel next to the seat and the console top with all the switches to get access. There are lots of wires in there! The CPU is attached to the left wall with 4 square drive screws. It has a 32 pin wire connector and a ground that also must be disconnected.

As side note: I have not yet tried, but I’m told if you cycle the cruise on/off on the steering wheel 3 times it will tell the cruise to ignore the Vorad and the cruise will operate normally. You will have to repeat this each time you turn the ignition key on.

I'm going to track down someone with a PC-based Vorad service tool, a Service Ranger 2.8, or a Pro-Link tool to diagnose the CPU and reprogram it.
Thanks to Mike Canter, DJ, Twomed, and others for the help so far.

pwhittle 02-05-2018 10:08 PM

Eaton Vorad model EVT-300 smart cruise issue
 
Vito,

Could it be the wiring for the left sensor is damaged?

That would be better than the main unit. It sounds like the sensor is not bad.

Paul

vito.a 02-27-2018 03:14 PM

Update: It has taken several weeks, but with Scott's help (Source Engineering) I finally tracked down Rick Youngblood. Rick is the Eaton engineer that did the original Vorad Smart Cruise integration work for Monaco back in 2003-2004. He also customized and updated the motor home software versions each year through 2010. If you adjust the range knob and it makes almost no difference, you may have an early software version (remember, this system was orginally designed for class 8 trucks).

Rick called and over the phone we ran through some diagnostic tests. He suspected a central processor issue, so I mailed my CPU to him in MI. He now has his old test bench up and running and is able to test and update Vorad systems. The BAD NEWS: My CPU had a VBus failure and was not repairable. The GOOD NEWS: I was able to purchase a new CPU with the latest RV118C software.

If you would like to update the software in your Vorad system, or need help with diagnostics, contact Rick at rjyblood@gmail.com.

Twomed 02-27-2018 08:30 PM

Congrats...perseverance pays!!

djhinds 02-28-2018 08:35 AM

Vito, that is excellent you found Rick. He updated my CPU years ago and it works great. I can change the following distance with the right knob from about 75 yards to about 150 yards. If I don't pay attention all of a sudden I notice I am down to 50 mph following someone and never felt the slowdown. All I do is check the left lane and if clear I change lanes, the forward looking radar see's a clear lane ahead and the boost comes up and in seconds I am at my cruise speed again without touching the throttle.

Safe Travels
Dave

K7JV 02-28-2018 09:20 AM

Fantastic, Vito!! I love it win a plan comes together!! So glad you're back in business. Cheers and safe travels!

djhinds 03-11-2018 10:20 AM

Vito.a, did you get the CPU back and installed and tested?? Just wondering....

Dave

vito.a 03-11-2018 06:54 PM

Yes, I received a new CPU with the RV18C software from Rick.
I installed it into the drivers side console and connected the 32 pin wire and the ground.
I now have both left and right sensors failed. Previously I had left sensor fail.

When I run the Vorad diagnostics it comes back with active codes 15 and 16 (left and right sensor) and inactive code 32.
When I check the Cummins ECU codes I get a "Smart Cruise J1939 Data erratic or failed" and Smart Cruise left and right sensor fail.

Very disappointing!
My 2004 coach has a chassis built in 05/2003, so it has the 6 pin J1708 connector under the steering wheel.
Do I have a J1939, or a J1708 engine bus? I'm wondering if I have the older J1708 bus and the new Vorad software is setup for the J1939.

Rick is sending two other CPU's for me to try.

djhinds 03-12-2018 07:12 AM

Vito.a, my coach is the exact same coach (04 sig Chateau) but has a Detroit 60. My coach build # is 603808. I do not know the build date or how to find it but the # should show if I was built before or after yours. I do have the 6 pin connector as yours does. Let me know if I can check anything on my coach for you......

Good luck
Dave

hypoxia 03-12-2018 08:42 AM

Vito.a, Interesting question about the engine bus and Vorad software. I have the J1939 and a similar problem. Haven't had a chance to work with Rick yet.

vito.a 03-12-2018 04:05 PM

Thanks. I need to understand more about the J1939/J1708 bus and what is in this coach.
Rick says Smart Cruise will not function with J1708 so we must have J1939. My 2007 coach had the newer 9 pin J1939 connector and this 2004 coach has the older 6 pin connector. Very confusing.

There is supposed to be a J1939 bus connector 2' back from the 32 pin Vorad connector. I tried to find it, but that drivers console has so many wires it is difficult! I have to pull the driver seat out anyway, so I'm going to see if I can find it then.

hypoxia 03-14-2018 08:51 AM

Vito.a, do you have the Vorad Installation Manual? I have 2, a 2004 edition and a 2007 edition.

https://www.roadranger.com/ecm/idcplg...ILE&dID=287180

https://riverparkinc.com/wp-content/...tall-guide.pdf

vito.a 03-14-2018 10:59 AM

Thank you Hypoxia and DJ for the install guides. I just read through the 2004, 2005, and the 2007 Vorad install guides. I can see the Vorad system progressed from the older heavy diesel J1708/J1587 to the newer J1939 bus.

I'm pretty sure my 2004 coach (05/2003 chassis) has the older J1708 data bus with a J1587 overlay. My new Vorad CPU with the RV 118C software is programmed for J1939. This may explain the bus fail on both the Cummins ECU and the Vorad. Each is looking for a different data stream.
However, I do not understand the Fail on both left and right Vorad sensors unless it's a by product of the bus mismatch. The Vorad CPU is communicating with the sensors through a discreet 3 wire set to each sensor.

I have my drivers seat removed (my new seats are done!) and the side console apart so I can trace the wires from the Vorad CPU. There are several 3-pin connectors near the 32 pin Vorad CPU connector and then the bundle goes through the floor.

I have a call in scheduled with Rick tonight. Hopefully we can figure it out.
Thanks!

hypoxia 03-15-2018 08:37 PM

I swapped side sensors yesterday and fortunately the problem followed the side sensor. I wonder if they are repairable?

I'll be sending the CPU to Rick for an update in a week or so.


All times are GMT -6. The time now is 10:41 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.