iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   RV Systems & Appliances (https://www.irv2.com/forums/f54/)
-   -   Slides and Leveling Jacks won't respond (https://www.irv2.com/forums/f54/slides-and-leveling-jacks-wont-respond-410357.html)

Fiishergurl 09-09-2018 04:13 PM

Slides and Leveling Jacks won't respond
 
Hi All,

We have a 2006 Itasca Ellipse 40KD Motorhome with hydraulic slides and leveling jacks that will not respond.

When pushing the slide in button you can hear a slight click but no response from any slide. Leveling Jacks will not go up or down.

We have added 2 quarts of hydraulic fluid, have manuals but cant find the fuse. Took chassis batteries and had them checked but they were good. Tried the battery boost but that didnt help.

Any ideas?

Thanks
Ginny

BirchyBoy 09-09-2018 04:55 PM

Our Class A has to have the parking brake applied before either of those systems work. Is yours the same way?

Ernie. 09-09-2018 04:58 PM

look for a circuit breaker in line near your house batteries, might have a round pop-up button or a flag arm that pivots out. had it happen to me, also generator wouldn't crank.

Skip426 09-09-2018 05:17 PM

2 Attachment(s)
If your system is HWH , the main 40 amp fuse on my system was within a foot of the pump/solenoid. Inline.

Mine looked like this; photo below;, lit up the control pad , but wouldn't pass enough power to operate anything.

If I have a picture showing location I'll post it.

EDIT: If you added fluid , when the jacks were extended , it will spill out as they retract, and overfill the reservoir..

Re-edit ; second photo ; zip tie; shows the location where the fuse was and I installed a 12 volt circuit breaker.

Ray,IN 09-09-2018 11:03 PM

You will find a wealth of information on the HWH website, including your owners manual and service information. Be sure to read the entire FAQ page too.
That said, a prominent member here is "azpete" he works for HWH and offers his advice and knowledge freely to help other members. Use the search box at the top of the page to locate one of his posts, then send him a PM by clicking on his screen name.

Skip426 09-09-2018 11:59 PM

Ginny; if your slide drive leveling system isn't HWH, please add that info to your post , as a few of us could be barking up the wrong tree .:whistling:

veraken 09-10-2018 05:28 AM

If your system is HWH, contact Paul at AZPETE on the Irv2 forum. He works for HWH and can answer your questions. His email is pfmaddox@att.net and his phone number is 602-549-3638. He is a Commercial Member and has posted that his phone is always on, and if not answered, leave a message.

He has helped other on this forum and I am sure he can help you

Fiishergurl 09-10-2018 06:06 AM

Quote:

Originally Posted by Skip426 (Post 4393187)
Ginny; if your slide drive leveling system isn't HWH, please add that info to your post , as a few of us could be barking up the wrong tree .:whistling:

Thank you everyone for the advice. Yes it is HWH. Going to check some of the things you all mentioned and will update later.

Thanks again,
Ginny

SoonToBeFT 09-12-2018 09:21 AM

Purely a FYI consideration, but when our hydraulic slide wouldn't come in on our 5er about 17 years ago, those "supposedly in the know more than us", kept adding hydraulic fluid.

Finally when I went into the bedroom with bare feet I felt a wet carpet and huge stench of the fluid = turned out that manufacturers had put the hose under the bed slide out and over time with it going in and out had created a hole in the tubing = just saying in case it's none of the above, might be worth checking any bad placement caused by friction as was our case.


All times are GMT -6. The time now is 06:30 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.