iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Class A Motorhome Discussions (https://www.irv2.com/forums/f258/)
-   -   Help with 210 series leveling system no power (https://www.irv2.com/forums/f258/help-with-210-series-leveling-system-no-power-461497.html)

viper2000675 09-15-2019 08:33 AM

Help with 210 series leveling system no power
 
Hi, looking for little help with leveling system on my 95 winnebago. It start at the campground last weekend. Went to put Jack's down to level and when I let go of joystick the motor kept running. Turned switch off and still running. Did everything I could to get motor to turn off but it just kept running. Finally i believe the pump just burned out and stopped. Got back home after the trip and replaced pump and solenoid. Did get leveling system to work once. Lights on panel use to come on but now nothing. Checked all fuses and made sure batteries were charged. Checked positive side at solenoid 12v. Checked small terminals on solenoid for power and got nothing. Took plate off control to inspect the three springs and clean. Tested parking brake to make sure it had power coming to control when engaged. Meter reading 12.9. Something like that and nothing when disengaged. So parking brake seems to be working but still no power or lights at controller but I did notice a small click when I turned on/off switch and then off. Again could hear the small click sound but no lights came on. Could the board be bad? Or maybe ground? Or I'm I just missing something? Any ideal or info on this issue would be appreciated. Thanks

Ray,IN 09-16-2019 11:18 AM

Over 80% of all 12V issues are the result of a poor/missing ground. Insure you have a clean, solid ground. An aside; always have the engine running when operating the jacks, as low voltage will cause problems.


All times are GMT -6. The time now is 09:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.