iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Class A Motorhome Discussions (https://www.irv2.com/forums/f258/)
-   -   98 Holiday Rambler Endeavor DP cruise not working (https://www.irv2.com/forums/f258/98-holiday-rambler-endeavor-dp-cruise-not-working-461552.html)

lawjohnson 09-15-2019 01:58 PM

98 Holiday Rambler Endeavor DP cruise not working
 
Anyone have any idea where they would have hidden the fuse for the cruise or if it even has one though I would think it should. I have looked on the front of the firewall and on the drivers side in the front compartment, (there are fuse banks in both locations), nothing marked cruise; no blown fuses.
The cruise does not engage. I had a rear lighting issue (brake, taillight, signals not working and the shop found that a hanger holding up the rear main wire loom had broken and the loom was laying on the drive shaft rubbing through the wires. We are thinking that the cruise wire was in that bundle and shorted out on the spinning drive line but for the life of me I can not find the fuse! It is driving me nuts and the DW and I are planning to leave for AZ in a little over a month.

TIA for any thoughts.

miniedmo 09-16-2019 04:37 AM

Hi Law, you have probably already checked this but on mine if the exhaust brake is on the cruise will not engage.

veraken 09-16-2019 06:25 AM

Try the Monaco Owners forum. There are many HR owners that belong to that forum. I have the same year, but different model. On mine it is located in the fuse box under the bed.


All times are GMT -6. The time now is 07:38 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.