iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   MH-General Discussions & Problems (https://www.irv2.com/forums/f84/)
-   -   Fuel pump issue (https://www.irv2.com/forums/f84/fuel-pump-issue-50611.html)

Shoulder 04-08-2009 06:39 AM

Fuel pump issue
 
I have a 1989 Fleetwood Pace Arrow. It is a Ford chassis with a gas 4bbl Holley carb. The fuel pump (electric right in front of the gas tank) was replaced by the last owner because when I went to buy it the pump wouldn't work. Well I don't think it was the pump that was bad. I wasn't involved with the repair (you can tell the pump is new).
The carb. keeps running out of fuel. so I checked the fuel pump inertia switch. I tried to reset it. It was not tripped. (camper hasn't been driven in 2 years). I checked the voltage at the relay connector (unplugged) with the key in the run position .5-.8 volts. Same voltage with the key in the off position. Turn the main power switch above the door off. The voltage reading goes to zero in all positions. When I turn the switch to start (while cranking) the voltage bounces between .6-5.12 volts. Plugged the connector back into the relay and probed the wires at the pump. The results are the same. This tells me the relay is ok. I jumped the pump with a 12v battery and the pump filled the carb with fuel and started.
Something is wrong in the wires but I can't find a fuse or a fuel pump relay so I have no idea where the short or break might be.
I checked both fuse panels under the dash and under the hood. I know in cars there is a fuel pump relay somewere (under the drivers seat in a mustang). I think the relay might be bad but I have no idea were to look. I don't want to run a bypass wire I really want to fix it the right way.Can someone PLEASE help me with this. I have been pulling my hair out trying to fix this.

Sorry its so long but I wanted to give as much info as I could.

Thank-you
Bob

Shoulder 04-09-2009 08:06 AM

I put a jumper wire across the oil pressure switch sender that I think is for the fuel pump. I also put a volt meter across it no voltage present with the key in any position. Now what??????????
Bob

dirko 04-09-2009 01:55 PM

Hi Ho Bob: It sounds like you are doing all the right things. Sorry I can't give you the answer, but maybe an electrical schematic for your rig would be a good start. Have you tried the Ford website? The problem is that vehicles that old may be hard to find info for.

Good luck, Dirk

ChasA 04-12-2009 10:32 AM

Sounds like a bad ground somewhere.

Shoulder 04-13-2009 03:20 PM

I didn't check the ford site but I did check the Fleetwood site and I could find any schematics:sad:
I am so *&%$^*&*^ mad at this thing. I don't know what to do.:banghead::banghead:
I can't afford to take it to a shop so I have got to figure this thing out.
My kids racing season has now started and we have no RV. With 5 kids a tent is not even an option:eek::eek:

Gary RVRoamer 04-14-2009 08:11 AM

You need to call Fleetwood Customer Service and request schematics based on the FIN (Fleetwood Id Number) or VIN. With them in Chapter 11, though, they may not have as much "customer service' available as they used to.

I would think a Ford service manual (make sure it covers the F53 Rv chassis) would be a better bet for this sort of problem. The fuel pump came with the chassis, not from Fleetwood.


All times are GMT -6. The time now is 04:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.