iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Alpine Coach Owner's Forum (https://www.irv2.com/forums/f104/)
-   -   Generator will not stay running (https://www.irv2.com/forums/f104/generator-will-not-stay-running-519328.html)

dennismhamm 12-26-2020 07:35 AM

Generator will not stay running
 
Gen 7500 diesel will fire up and run for about 5 seconds then shuts down. I have changed the temp sensor but did not help at all. If anyone has any info your help will be most appreciated. Thank you in advance.

dave&ginny 12-26-2020 07:46 AM

Quote:

Originally Posted by dennismhamm (Post 5572125)
Gen will fire up and run for about 5 seconds then shuts down. I have changed the temp sensor but did not help at all. If anyone has any info your help will be most appreciated. Thank you in advance.


There's a governor control that sometimes will vibrate loose. I had this happen with one of my generators years ago. If you look around the linkage you'll see 2 adjustment screws, don't move them much but move them a little. These keep the RPMs at an exact level

good luck

lazybyrd 12-26-2020 07:59 AM

Dumb question but you have to start somewhere... plenty of fuel in the tank? Fuel filter changed recently?

dennismhamm 12-26-2020 08:01 AM

yes. fuel tank is full also just changed the oil fuel filter and air filter

Old Scout 12-26-2020 08:06 AM

Possibilities: oil pressure, water pump belt, internal electronic control issue, fuel supply, or battery bank charging issue....but as mentioned, most of these would/should create a control panel fault code [blinking lights]....

lazybyrd 12-26-2020 08:06 AM

Oil and coolant levels ok?
No codes?

dennismhamm 12-26-2020 08:11 AM

it was showing a code of 24 which suggests temp sensor and i chaned that but did not help

Old Scout 12-26-2020 08:13 AM

…..so water pump belt was ok?

lazybyrd 12-26-2020 08:16 AM

Another question...showing my ignorance here, when a code is generated is there a process by which you need to reset?

dennismhamm 12-26-2020 08:19 AM

old scout. it looked ok? what would i look for as far has the water pump belt?

deandec 12-26-2020 10:04 AM

I had that problem when the generator radiator fan belt was loose.

Many Generator Manuals have a step by step Trouble Shooting flow chart at the back of the booklet. :thumb:

Usually separate sections for engine problems and generation problems.

LETMGROW 12-26-2020 10:12 AM

Recent oil change. Recheck the oil level.
Was it running OK before the oil change?

Old Scout 12-26-2020 01:59 PM

…..sounds good...its mostly an age thing other than belt tension....Onan doesn't use a tension pulley so belt provides its own tension once installed on the pulleys....this belt doesn't get a lot of work so as long as its intact [eg not shredding], its probably ok....

dennismhamm 12-26-2020 05:03 PM

it started about a week ago


All times are GMT -6. The time now is 10:56 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.