iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Entegra Owner's Forum (https://www.irv2.com/forums/f278/)
-   -   Cornerstone water pump (https://www.irv2.com/forums/f278/cornerstone-water-pump-523354.html)

RVFunlovers 01-31-2021 12:16 PM

Cornerstone water pump
 
My water pump stopped working yesterday. I rarely dry camp so it is generally just used when we are traveling to flush a toilet or run sink water for hand washing.

I checked the circuit breaker and it is ok. Pump makes a hum noise that you can hear and I can feel the pump vibrate but no water output.

Plenty of fresh water in the tank. I checked the little filter on the pump and it is clean. I tried to stick the clear plastic hose in a bucket of water and get no suction no matter what position I put the clear hose valve in. I was thinking that might be to prime the pump.

I think my pump is bad. Any ideas?

It was working fine. Now it is not. I have let is run several times for a while but no output. All water working ok when connected to city water. My water fill switch is in city water position. But I tried it both ways.

If I do need a new pump:

How do I figure out exactly what pump I need to purchase?

The pump looks hard to get to. Do I remove the entire wet bay panel to change the pump or do I try reaching in from the smaller rectangle access panel opening?

JGilchrist 01-31-2021 12:51 PM

I had a similar situation recently after emptying my fresh tank. Pump worked fine before I drained the tank and didnít use until two weeks later when I left the resort. My pump hummed and vibrated but would not pump water. Turns out I sucked a bunch of air in the system as I used the pump to try to empty the tank quicker beside just opening the drain valve. A full timer mechanic at the resort helped me and I believe he forced water to the pump then let it run to get the air out. There is a thread here somewhere explaining the same procedure. I apologize I was not there to watch as he repaired it. Maybe this will be your solution before replacing the pump.

Skip426 01-31-2021 01:02 PM

Without seeing your system , I believe the clear hose and valve , are for winterizing and pumping RV anti-freeze from a jug through the coach .

If your not getting water flow after a long period of pump run , then good chance the pump is the problem . Make and model info will be on the pump .
Some makes there is a valve head available if the motor runs. :thumb:

jrugarber 01-31-2021 01:10 PM

3 Attachment(s)
Hal,

Not sure I can be of much help in diagnosing the problem but there are plenty of Posts relating to failure and/or troubleshooting of the pump. I have attached a picture of the SHURFLO pump 4048 that I purchased as a spare and 2 pictures of the wet-bay and area of the pump. I would think that if you were to replace the pump it would be done thru the rectangular opening vs. taking all the associated connections, electrical and plumbing off, remove the panel, remove/replace the pump then put everything back together!
Let us know what the final outcome was when you find out.

Safe travels.

Rollin101 01-31-2021 01:39 PM

Quote:

Originally Posted by RVFunlovers (Post 5617536)
My water pump stopped working yesterday. I rarely dry camp so it is generally just used when we are traveling to flush a toilet or run sink water for hand washing.

I checked the circuit breaker and it is ok. Pump makes a hum noise that you can hear and I can feel the pump vibrate but no water output.

Plenty of fresh water in the tank. I checked the little filter on the pump and it is clean. I tried to stick the clear plastic hose in a bucket of water and get no suction no matter what position I put the clear hose valve in. I was thinking that might be to prime the pump.

I think my pump is bad. Any ideas?

It was working fine. Now it is not. I have let is run several times for a while but no output. All water working ok when connected to city water. My water fill switch is in city water position. But I tried it both ways.

If I do need a new pump:

How do I figure out exactly what pump I need to purchase?

The pump looks hard to get to. Do I remove the entire wet bay panel to change the pump or do I try reaching in from the smaller rectangle access panel opening?

I think Entegra started installing the shutoff valve, in 2017, to the pump so water canít fill your tank while hooked to city water. If that valve is closed pump cannot pump water. The valve is in line going to pump. Of course if you havenít closed it that shouldnít be the problem.

757driver 01-31-2021 02:27 PM

Quote:

Originally Posted by RVFunlovers (Post 5617536)
My water pump stopped working yesterday. I rarely dry camp so it is generally just used when we are traveling to flush a toilet or run sink water for hand washing.

I checked the circuit breaker and it is ok. Pump makes a hum noise that you can hear and I can feel the pump vibrate but no water output.

Plenty of fresh water in the tank. I checked the little filter on the pump and it is clean. I tried to stick the clear plastic hose in a bucket of water and get no suction no matter what position I put the clear hose valve in. I was thinking that might be to prime the pump.

I think my pump is bad. Any ideas?

It was working fine. Now it is not. I have let is run several times for a while but no output. All water working ok when connected to city water. My water fill switch is in city water position. But I tried it both ways.

If I do need a new pump:

How do I figure out exactly what pump I need to purchase?

The pump looks hard to get to. Do I remove the entire wet bay panel to change the pump or do I try reaching in from the smaller rectangle access panel opening?

If you have the Shurflo 4008 pump the most likely problem is the internal check valve (rubber, about 3/4Ē diameter) is stuck closed and the pump pressure is not enough to open it back up. I had this happen on mine several times before I replaced the pump with a different brand.

The check valve is located inside the black plastic end with the 8 screws. I removed this end and pushed the check valve with my finger to release it. Might want to lube with a thin film of plumbers grease. Re-assemble and you should be good to go.

brobox 01-31-2021 03:45 PM

Here are several posts on how to prime the water pump. https://www.google.com/search?client...the+water+pump

RVFunlovers 01-31-2021 03:46 PM

Thanks for the help. I am going to try to release the check valve. And at least figure out what exact pump I have so I can order a new one if needed.

brobox 01-31-2021 03:55 PM

Hal, I would try a simple priming the pump first. If the pump is running, that's a good chance of the problem. The check valve problem normally is the tank over filling.

oneknight 01-31-2021 06:22 PM

Most likely it just needs to be primed.

Put the outside shower on the ground, turn it on, and open it's cold valve.
Hook a hose to the shore water inlet.
Turn on the hose and the pump.
Water will come out the hose. Let it run til it's not spitting air.
Work the city/tank valve. city. tank. city tank. repeat until the pump builds pressure.

Remember with the valve in city, the pump never builds pressure.
flip it to tank, once it's primed it should build pressure and stop.

757driver 02-01-2021 03:47 PM

Quote:

Originally Posted by brobox (Post 5617915)
Hal, I would try a simple priming the pump first. If the pump is running, that's a good chance of the problem. The check valve problem normally is the tank over filling.

Chuck,

The tank overfilling would be the check valve sticking open. Mine always stuck closed. You hear the pump running but zero water coming out of any tap. These pumps are for the most part self priming so I cannot see it as a priming problem.

757driver 02-01-2021 03:49 PM

Quote:

Originally Posted by RVFunlovers (Post 5617893)
Thanks for the help. I am going to try to release the check valve. And at least figure out what exact pump I have so I can order a new one if needed.

If it is a Shurflo 4008 I would not replace it with the same model. The 4048 model does much better.

brobox 02-01-2021 04:23 PM

Quote:

Originally Posted by 757driver (Post 5619348)
Chuck,

The tank overfilling would be the check valve sticking open. Mine always stuck closed. You hear the pump running but zero water coming out of any tap. These pumps are for the most part self priming so I cannot see it as a priming problem.


I see what your saying, mine was the opposite filling the tank. I did get an air lock in my water system and had to prime the pump and force the air lock out.


Quote:

Originally Posted by 757driver (Post 5619352)
If it is a Shurflo 4008 I would not replace it with the same model. The 4048 model does much better.

Totally agree, it's an easy upgrade and well worth it.
After my air lock I felt the 4008 was not enough water pump for the system and changed it to the 4048 for that reason.

RVFunlovers 02-01-2021 05:25 PM

I believe I have a 4008. If I have to get a new pump I will get the 4048. The weather has been unpleasant the past two days so I have not messed with the pump. I am going to try to get my current pump going but I think I will need a new one.

The pump looks hard to get at. But thankfully Amazon sells the 4048 with 2 day shipping.


All times are GMT -6. The time now is 08:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.