iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Newmar Owner's Forum (https://www.irv2.com/forums/f103/)
-   -   New RV made it home (https://www.irv2.com/forums/f103/new-rv-made-it-home-52877.html)

dportem 05-31-2009 09:10 AM

New RV made it home
 
Got home from TX on Friday. We picked up the 04 dutchstar on Thursday changed all the fluids and drove straight to Fort lauderdale. Wow, I never knew the C7 engine was so perfect. The generator had 130 hrs. on it and purred like a kitten all the way home. The only problem was the condition of the right front tire. Grooved badly down the middle. Looks like two new drivers and an alingment. Just as we were getting home the turn signals crapped out? I hope to find out where the fuse box is soon?

The family and I spent all day yesterday cleaning her out. What a land yacht, floor, walls, ceiling, everything! Then took the family for a little drive and put her in the yard until our trip in two weeks.

So the only problems, so far are two new tires, fuse? and the jacks. Well while at my house I put her up and when I was ready to leave dropped her and all but one came up. I tried up and down two more times called my buddy who told me to try a 2x4 and puss it up. Worked! He thinks it's just from sitting in the TX desert for a year or so. Anywho, thanks for the info. I'll be putting in the 32 and 26 tv next week, hopefully. Josh

Jim Stewart 05-31-2009 09:24 AM

Congrats! You may want to check the Hydraulic Fluid (Dex III, I think) for the jacks. Put them all the way down, spray silicone on the shiney part and put them up and down again a few times. Hope this helps!

GaryKD 05-31-2009 04:18 PM

HI Josh,
Congrats on the DSDP. Welcome to the Newmar family. This is an exciting time for the family and you. Many happy miles are ahead of you.

Check out the NKK sub forum. The NKK is for owners of Newmar products. The International Rally is the first week in August.

rjf7g 05-31-2009 10:02 PM

Congrats on your new rig.

"007" 06-01-2009 08:37 AM

Congrats Josh, just remember maybe a defective lamp or poor ground and lube the jack pistons with silicone lube and wipe off and work them a few times haven't been use in a while.

Ronnie Bledsoe 2006 Dutchstar 43' 06-01-2009 09:00 AM

Congratulations and welcome to the Forum and Newmar Family. The Newmar Kountry Klub offers quite a few events and local clubs...consider joining.

Latitude 06-01-2009 07:08 PM

Hey Josh!!

Bottom Line!!

Have "FUN"

Rick

EngineerMike 06-01-2009 08:04 PM

If the jack doesn't come up at all it may be a solenoid in the HWH system. Don't replace the solenoid for that jack w/out a diagnosis. The way they are wired, the solenoid for the other jack at that end of the coach might be the problem. You can call HWH @ their 800# for help w/the diagnosis.


All times are GMT -6. The time now is 02:54 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.