iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Newmar Owner's Forum (https://www.irv2.com/forums/f103/)
-   -   Need some Newmar pro help (https://www.irv2.com/forums/f103/need-some-newmar-pro-help-540910.html)

twoolchefs 06-12-2021 03:32 PM

Need some Newmar pro help
 
Hi everyone! Have not posted as of yet but watch the forums like a hawk to sponge up all the info we can! We picked our gorgeous "new to us" Dutch Star 3865 DP Friday and driving back to Iowa...she's a wild tigress running like a champ! We are already in love. Just need a bit of advice. Our Onon Gen fires up like a pro. However we cannot get any electrical to light. We expect bumps and, since we are traveling with no tools, we realize not a chance to do much work on anything. Just thinking maybe this is newbie ignorance and one of you pros might be reading this and laughing because you see our silliness. Will tie into shore line when we get home but have one night till we get home. Thanks in advance if anyone can shed some light!
Old Chef #2 a.k.a. Darrah

oldcoon 06-12-2021 03:36 PM

Check the breaker on the generator itself.

Dutchstar411 06-12-2021 03:48 PM

Assuming you have shore power when hooked up and everything 120 volt works, then check the breaker on the generator as just mentioned. If you haven't hooked up to shore power, check the main breakers in the fuse panel inside the coach.

Dutch Star Don 06-12-2021 04:02 PM

2 Attachment(s)
Often, when they're prepping a new coach, they turn the circuit breaker off on the nose of the generator, so it doesn't auto start. Like "Dutchstar411" suggested, check that breaker. It's good to keep in mind that if you lose power on a trip, while running the generator, this is the first thing to check.

The second photo is the nose of the generator. The circuit breaker is on the bottom right of the panel.

Attachment 331883

Attachment 331884

twoolchefs 06-12-2021 11:06 PM

Thanks!!
 
Thanks tons for the information! Checking when we get home tomorrow. He flipped both breakers on the Gen and no change. He will check the auto breakers on the batteries and also check to see if the transfer switch is working...has anyone ever had the transfer switch stuck in shore power? I will keep yall posted
TIA!

Skip426 06-12-2021 11:25 PM

Welcome to iRV2 . and the Newmar family . :flowers:

What year is your Dutchstar ?

twoolchefs 06-13-2021 06:02 AM

She's a 1997. She was never boondocked so it makes us think it may be the transfer switch. She has a couple minor issues from sitting for 2 years when the original owners got too old to drive her. Yall are so generous with your experiences that I know with your help in the forums we are going to bring her back to a lovely home!

Skip426 06-13-2021 08:17 AM

1 Attachment(s)
Quote:

Originally Posted by twoolchefs (Post 5789334)
She's a 1997.

Well I don't know how many changes Newmar made between your 97 and my 99, but here's a picture of may power cord bay , with the transfer switch on the back wall ; lower left . If your transfer switch is also a Todd Engineering product ( they're out of business ) I have the original paper work with testing information if you need it.
I've used this photo before and don't know how to erase the circles and arrows .

twoolchefs 06-13-2021 08:26 AM

Wow great!! Home in 2 hours and hoping hook in will show us the way...seems like a bit of an easy fix so hoping we will lock it fast! Thanks tons...lol the difference between the two is ours is upper left where yours is lower left. Thank you so much!

"007" 06-13-2021 04:10 PM

Welcome to the forum.
Some links to old MH's can be found in my signature at the bottom of this link with much more stuff.
Enjoy the forum and safe travels.

twoolchefs 06-14-2021 11:37 AM

Thanks yall!! Home and hooked into our portable Gen with shore line and she works like a young pup. Even the steps are working! Lolol Cold air and all electric up and running. Just have to figure what's up with rv Gen and connecting to system. We are incredible happy!! Good Chefs!! I am sure I will be back with more questions!! Lolol Yall are wonderful to help with answers!! Have a great day everyone!!

spsm 06-14-2021 11:46 AM

check your RV generator ground.

Dutchstar411 06-14-2021 12:55 PM

Quote:

Originally Posted by twoolchefs (Post 5791223)
Thanks yall!! Home and hooked into our portable Gen with shore line and she works like a young pup. Even the steps are working! Lolol Cold air and all electric up and running. Just have to figure what's up with rv Gen and connecting to system. We are incredible happy!! Good Chefs!! I am sure I will be back with more questions!! Lolol Yall are wonderful to help with answers!! Have a great day everyone!!

While on shore power, start your GEN and see if your ATS tries to switch over to GEN. If it doesn't click over then either the GEN is not producing current to the ATS or the ATS is bad.

twoolchefs 06-15-2021 07:14 AM

Thanks! going to do that straight away...it clicks if it switches, correct?


All times are GMT -6. The time now is 06:09 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.