iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Entegra Owner's Forum (https://www.irv2.com/forums/f278/)
-   -   Diesel fuel gauge (https://www.irv2.com/forums/f278/diesel-fuel-gauge-541998.html)

Prairie Dog 06-20-2021 12:59 PM

Diesel fuel gauge
 
My fuel gauge appears to be stuck on full. Anyone have experience with this malfunction? Thanks

Gary.Jones 06-20-2021 01:06 PM

Bill

Yes.... I had that problem for about 6 months with my 19 Cornerstone and that was exactly my guess as to what the problem was. I brought this up to Spartan when I had my 2 year AIR in Middlebury and went to Spartan immediately after in early November.

My tech, Andy, was a very experienced guy there and he said that type of problem was rare, but he largely solved it by dropping the diesel tank completely out of the frame, then installing a new sensor (largely a metal float that floats on a rod that protrudes down into the tank and slides up and down that tube as the fuel goes up and down. As you might guess, on my coach that rod and float sensor installs from the top and there is no way to remove it without removing the tank. So, the tank came out, a new sensor was installed, then he had to weld the tank back between the chassis supports and fini.... took most of a day including pumping the diesel out of the tank and back in after done.

Now, I say largely resolved. I have put maybe 5,000-6,000 miles on the coach since the sensor mechanism was replaced and twice, the gauge again froze up at the top and showed full all the time even if I drove 800 miles (obviously not full) but now in the past 4,000 miles or so, the gauge has been accurate.

I found that I always reset trip 2 on my digital dash (if you have that feature) and I could reliably drive 800-900 miles before refueling and ignoring the fuel gauge. I was very careful as I certainly did not want to chance a tow. So I did it from the odometer mileage and with the trip mileage and it worked well.

Gary

Prairie Dog 06-20-2021 01:14 PM

Quote:

Originally Posted by Gary.Jones (Post 5798994)
Bill

Yes.... I had that problem for about 6 months with my 19 Cornerstone and that was exactly my guess as to what the problem was. I brought this up to Spartan when I had my 2 year AIR in Middlebury and went to Spartan immediately after in early November.

My tech, Andy, was a very experienced guy there and he said that type of problem was rare, but he largely solved it by dropping the diesel tank completely out of the frame, then installing a new sensor (largely a metal float that floats on a rod that protrudes down into the tank and slides up and down that tube as the fuel goes up and down. As you might guess, on my coach that rod and float sensor installs from the top and there is no way to remove it without removing the tank. So, the tank came out, a new sensor was installed, then he had to weld the tank back between the chassis supports and fini.... took most of a day including pumping the diesel out of the tank and back in after done.

Now, I say largely resolved. I have put maybe 5,000-6,000 miles on the coach since the sensor mechanism was replaced and twice, the gauge again froze up at the top and showed full all the time even if I drove 800 miles (obviously not full) but now in the past 4,000 miles or so, the gauge has been accurate.

I found that I always reset trip 2 on my digital dash (if you have that feature) and I could reliably drive 800-900 miles before refueling and ignoring the fuel gauge. I was very careful as I certainly did not want to chance a tow. So I did it from the odometer mileage and with the trip mileage and it worked well.

Gary



Thanks Gary, great info as usual

Nowabeachbum 06-20-2021 01:37 PM

I just experienced this 2 days ago. I reset the chassis power located back by the chassis batteries and it went back to reading normally.

Prairie Dog 06-20-2021 01:45 PM

Quote:

Originally Posted by Nowabeachbum (Post 5799021)
I just experienced this 2 days ago. I reset the chassis power located back by the chassis batteries and it went back to reading normally.



Good to know. Will try that. Thanks. My Charlotte, MI appt isnít until Oct

RMatusick 06-20-2021 03:11 PM

I also had the same issue but mine was stuck on empty. Reset the chassis power and it went back to normal.


All times are GMT -6. The time now is 10:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.