iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   MH-General Discussions & Problems (https://www.irv2.com/forums/f84/)
-   -   Guardian 75D Troubleshooting (https://www.irv2.com/forums/f84/guardian-75d-troubleshooting-542662.html)

bduemig 06-24-2021 05:01 PM

Guardian 75D Troubleshooting
 
I was working in my motorhome today ( 87 degrees outside). I was running both A/C's. suddenly lost power but it came back pretty quick. Ran for about 20 minutes and power went off again. The generator was running, just no voltage. I shut down the generator, checked coolant and oil. All good. Restarted generator, had no power. After about 5 minutes, power came back on.



It loses A/C power without affecting the engine.



Could not find a troubleshooting tree with that type of problem.



Any ideas?

Randy125 06-26-2021 08:50 AM

Is your unit a Quietpact 75D Generac?

bduemig 06-26-2021 07:09 PM

Yes it is.

Randy125 06-27-2021 07:08 AM

Maybe this link will help.
https://www.generator-parts.com/manua...-rv/0F4996.pdf

bduemig 06-27-2021 08:36 AM

Thanks for the link. I did look n at that manual. I am going to get a watt meter to do complete checks on the generator.

bduemig 07-16-2021 05:22 PM

Might have figured it out. Yesterday, we were traveling from Dallas and started the generator. It worked fine for a few miles then quit.
When I stopped, I tried to start it and it would turn over, but would not start. Hitting the preheat switch sounded like a relay clicking on and off. I thought it was 12v dc power or a fuel pump.

Easiest thing was to check the battery cable m. Sure enough, it was corroded. Changed the connector and problem solved. At least so far it has worked without issue.

Randy125 07-17-2021 09:48 AM

That’s good to hear.

bduemig 07-24-2021 12:33 PM

Well, I thought it worked. Now it won't start at all. There is a loud clicking noise from the fuel pump. That makes me assume it is a bad pump.

Any ideas of an aftermarket pump since the oem isv300 dollars.

Randy125 07-25-2021 09:31 AM

Any possibility that the pump could be rebuilt?

bduemig 07-25-2021 10:10 AM

I am not sure but I don't think so. I am going to get some fuel line and run it from the pump inlet to a container with diesel in it to make sure it isn't a deteriorated fuel line. It is a 2004 dry root is a possibility.

bduemig 07-27-2021 07:14 PM

Well, a new dilemma. I was just under half a tank of fuel when I had fuel problems with the generator. As soon as I filled up, I hit the preheat switch and after about 4 seconds, the clicking stopped and the generator fired up and never quit.

Weak fuel pump?
Clogged vent line for the fuel tank?
Manufacturer put the pickup tube too high on the tank?

Any suggestions?

Randy125 07-28-2021 06:53 AM

Very possible the pickup is too high in the tank.

bduemig 07-28-2021 06:56 AM

Thank you. I would assume there is nothing that can be done about that short of removing the tank.

bduemig 08-30-2021 08:25 AM

Quote:

Originally Posted by Randy125 (Post 5849730)
Very possible the pickup is too high in the tank.

Does anyone know if the generator pickup line can be adjusted?


All times are GMT -6. The time now is 09:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.