iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Newmar Owner's Forum (https://www.irv2.com/forums/f103/)
-   -   DEF loosing pressure (https://www.irv2.com/forums/f103/def-loosing-pressure-554729.html)

Arty1313 09-20-2021 02:55 PM

DEF loosing pressure
 
I have had the head sensor replaced per the code it was showing.
Then the Tech said it was loosing pressure so they replaced the Dozer Valve for the second time and also the Dozer Pump and it still is not holding pressure and now Cummins is saying the filter in the tank is causing the problem and it has to be replaced....the problem there 30 to 40 days before they can get one.
I asked the shop to at least check for a bad o ring or crossed hose? said Cummins told him not to touch it til the filter is replaced. Spartan Chassis

arcaguy 09-20-2021 03:13 PM

I think I would start looking for a new mechanic. Your current mechanic is not diagnosing the problem, he is replacing parts until he finally replaces the right one, all on your dime. Good for his pocket and bad for yours.

Arty1313 09-20-2021 03:50 PM

Well the good thing is, it still is under warranty , but I tend to agree with you, with what I have been through with these people, but my hands are tied.
Thanks for the input.

Dutch Star Don 09-20-2021 07:00 PM

Find the part number for yours and see if they're truly out of stock. I just looked up the one for Cummins and is used in my Freightliner. Found several in stock.

https://www.ebay.com/itm/19402352354...e36df1843d71b0

Arty1313 09-21-2021 11:28 AM

Thanks for the Information Don, Iím waiting on a call from Spartan, they think they have located one, if not I have it is in Canada OEM part.
Iím not a mechanic but honestly I donít think that is the problem but it is under warranty and the shop told me that Cummins said not to do anything to it until the filter was replaced.


All times are GMT -6. The time now is 08:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.