iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Freightliner Motorhome Chassis Forum (https://www.irv2.com/forums/f26/)
-   -   erratic fuel gage (https://www.irv2.com/forums/f26/erratic-fuel-gage-555832.html)

PandS 09-28-2021 10:46 AM

erratic fuel gage
 
Yesterday, as we were going down the road, the fuel gauge began bouncing between the correct reading and empty. The LBCU displayed LOW FUEL! and the audible alarm sounded.


We had plenty of fuel and there was no loss of power. Eventually, it settled down, but clearly, something isn't right.


Anyone on here had this happen in the past? -Thanks in advance! -Paul



2017 Newmar Ventana, Freightliner chassis

Scepter40 09-28-2021 11:08 AM

First place I'd check is all the grounds in the fuel gauge system, starting at the wiring on the tank. Then to the gauge itself. Mine doesn't read great, and while there's a calibration process for my era of coach, the wires on the top of the tank are extremely dirty/greasy. My guess is they aren't making good enough contact.

rvbiker45 09-28-2021 06:34 PM

My fuel level pick up, the float in the tank, is mounted on the side. The access is a black screw opening like for the sewer hose opening. It is in the front passenger compartment. I opened that access and tightened all of the bolts that secure the fuel sending unit to the tank. The problem has never returned. I think the sending unit grounds to the tank and by it being loose, the continuity was broken.

2cyber71 09-28-2021 06:46 PM

My 2007 Ellipse 40FD needed a sending unit.
Some need the fuel tank removed to replace

dp7 09-28-2021 11:51 PM

Quote:

Originally Posted by PandS (Post 5931168)
Yesterday, as we were going down the road, the fuel gauge began bouncing between the correct reading and empty. The LBCU displayed LOW FUEL! and the audible alarm sounded.


We had plenty of fuel and there was no loss of power. Eventually, it settled down, but clearly, something isn't right.


Anyone on here had this happen in the past? -Thanks in advance! -Paul



2017 Newmar Ventana, Freightliner chassis

Mine has done the same intermittently for the last 18 months. Never does it when in for service. :facepalm:

gatorcq 09-29-2021 07:37 AM

Doing a little searching on this forum, you would have saved yourself some time. The normal issues are gauge, wire connection, then sending unit.


All times are GMT -6. The time now is 04:48 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.