iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Travel Trailer Discussion (https://www.irv2.com/forums/f50/)
-   -   Buzz from audio unit (https://www.irv2.com/forums/f50/buzz-from-audio-unit-557954.html)

Swampmonkey 10-16-2021 10:29 AM

Buzz from audio unit
 
i have a 1987 gulf stream the audio system (car radio) that i installed taking power and ground off of the trailer just hums when turning it on when connected to 110 house current it seems to work fine when on 12 volt system (not plugged in ) is their a fix or has anyone run into this and how did ya fix it

Jim_HiTek 10-16-2021 12:06 PM

Yeah, I did with my '94 Bounder. I added this device to my audio and that took care of it...but don't ask me where I wired it in, I forget: Audio Filter

arcaguy 10-16-2021 12:16 PM

Before you spend any money you might try grounding the metal case to trailer frame. Good luck.

Swampmonkey 10-16-2021 04:29 PM

a ffew more items i found during inspection found that audio (car stereo will work with out the ground being supplied its in a wooden cupboard so it shouldnt be supplying the ground ive unplugged all the speakers from the radio one at a time still works im a 30 year auto tech and this has me totally baffled any help would be appreciated I did rewire a trailer lead into this trailer due to road raash on the original plug thank you for any assistance


All times are GMT -6. The time now is 02:02 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.