iRV2 Forums

iRV2 Forums (https://www.irv2.com/forums/)
-   Newmar Owner's Forum (https://www.irv2.com/forums/f103/)
-   -   I think my DS has a psychotic thermistor (https://www.irv2.com/forums/f103/i-think-my-ds-has-a-psychotic-thermistor-558587.html)

USMCRET 10-21-2021 08:22 AM

I think my DS has a psychotic thermistor
 
I noted some odd A/C behavior last evening in my kitchen A/C zone. When I checked the KiB HVAC display, that zone was reporting an ambient temp of 32 deg and was bouncing around a bit. This morning the temp is correct.

I think this points to an intermittent electrical connection somewhere. Any suggestions on where to begin looking?

plane 10-21-2021 08:28 PM

Quote:

Originally Posted by USMCRET (Post 5957607)
I noted some odd A/C behavior last evening in my kitchen A/C zone. When I checked the KiB HVAC display, that zone was reporting an ambient temp of 32 deg and was bouncing around a bit. This morning the temp is correct.

I think this points to an intermittent electrical connection somewhere. Any suggestions on where to begin looking?

I have been fighting this for some time on my coach, it continues to get worse and now preventing my use. I have taken it to 2 dealers that have replaced the thermistor 3 times and it worked for a short time, which Dometic says is super rare for one to go bad. With it taking 2 months to schedule an appointment I called a mobile tech who changed the control board. I worked great for about an hour and then started to go back to 32 degrees. I believe the 32 degrees means something not sure what it is though, tech coming back the end of next week to try again and maybe this time will change the freeze sensor, I am getting very frustrated and have even been talking to silverleaf folks. Please post if you find out what is causing this.

USMCRET 10-22-2021 06:21 AM

Quote:

Originally Posted by plane (Post 5958499)
I have been fighting this for some time on my coach, it continues to get worse and now preventing my use. I have taken it to 2 dealers that have replaced the thermistor 3 times and it worked for a short time, which Dometic says is super rare for one to go bad. With it taking 2 months to schedule an appointment I called a mobile tech who changed the control board. I worked great for about an hour and then started to go back to 32 degrees. I believe the 32 degrees means something not sure what it is though, tech coming back the end of next week to try again and maybe this time will change the freeze sensor, I am getting very frustrated and have even been talking to silverleaf folks. Please post if you find out what is causing this.

Thanks for the reply, Jim. I found a thread on here from a few owners of coaches with the silver leaf system. They found a loose wire connection in the basement area of the coach due to the use of wire nuts. I am hoping there is a similar situation involved with mine and that someone has dealt with it before on a DS. I do not believe it is the thermistor, per se, that is the problem, but of course I could be wrong. Good luck with your issue as well.

jimjenturner 10-22-2021 08:54 AM

Just my thought
 
Most Thermisters as the temperature raises the resistance goes down and when temperature lowers the resistance raises. That being said since you are reading 32 my guess is there is loose connection or a wire that is making and breaking connection.

plane 10-22-2021 11:34 AM

Quote:

Originally Posted by jimjenturner (Post 5958905)
Most Thermisters as the temperature raises the resistance goes down and when temperature lowers the resistance raises. That being said since you are reading 32 my guess is there is loose connection or a wire that is making and breaking connection.

While trying to track down the issue the mobile tech using his ohm meter and checking the thermistor resistance found that the resistance in the thermistor wires were correct for the inside temp of the coach indicating the thermistor was sending the correct temp, but what the silver leaf was reading was 32 degrees. He then check the AC circuit board and found what appeared to be some arcing and a loose wire and so replaced the board and it came up and showed the correct temp and begun cooling, I check again in about an hour or so and the air compressor had drop out and the fan was blowing and ssilverleaf temp showed 32 degrees.

I did call silverleaf to discuss with them and they said that in 2018 to 2020 or 2021 Newmar installed a battery bridge solenoid on all coaches made with a White Rogers and it did not have a diode and that before replacing anything I should first replace it with a Amtec #140045 or install a diode as it has cause some issues silverleaf control boxes and to eliminate current or future problems.so I have one to install next week.

I went out last week to check the coach and the temp was showing 69 so I tried the AC again and as soon as it was turn on I watched the temp count down to 32 degrees again. The 32 degrees seems to be a constant in all of this so in disparation I will have the tech check the freeze temp sensor.


All times are GMT -6. The time now is 05:37 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.